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Preface 
EM3D is a multi-platform application designed to align, reconstruct, segment, model, and analyze 
electron microscope tomography data. EM3D is compatible with Macintosh, and Windows. Each 
dataset consists of a series of two-dimensional transmission electron microscope (TEM) images 
recorded on a CCD camera at regular tilt intervals, for instance, ±70º at 1º increments; fiducial markers 
must be visible on each image to facilitate alignment. EM3D will also load, align, and merge dual axis 
datasets contain two series of projections taken at perpendicular angles to one another. 
 
EM3D is being developed in the Laboratory of Dr. U. J. McMahan (Professor of Neurobiology and of 
Structural Biology at Stanford University School of Medicine), and is funded by National Institute of 
Mental Health (MH068065). EM3D software is the joint effort among cellular and molecular 
biologists, who use it daily, and the computational biologists and engineers who develop it. 
 
EM3D 1.X was developed by Dr. David Ress, David Yip, Cornelia Koch-Stoschek, and Mira Raman 
in the IDL environment.  EM3D 2.X was developed by David Yip in Java/C++.  

This tutorial is designed to instruct a new user in the analysis of EM tomography data using a small 
synthetic dataset.  The tutorial guides the user through the processes of importing the tilt series, 
aligning the projections, reconstructing the projections into a tomogram, combining dual axis data, 
segmenting objects of interest, and doing 3D renderings.  A manual is available for more in-depth 
information on how to use EM3D V2.0. Details on acquiring the EM3D application and the Synthetic 
dataset can be found at http://em3d.stanford.edu. 
 
EM3D has the typical benefits and liabilities of early software releases. Nevertheless, major efforts are 
being made on many levels to make this new version of EM3D intuitive, stable, and easy to use. The 
IDL version of EM3D has been used since 1997 with excellent results in discovering new structures at 
the 2-3 nm scale and efforts to improve features and performance continue. 
 
This software is released expressly for Research Purposes Only. 

 



1 Getting Started 
 All users should read this section before running EM3D for the first time. 

1.1 An introduction to this text  

1.1.1 Main sections of text 
 
This text is divided into 2 main sections and an Appendix.   
1. Getting Started - This section contains all the information necessary to 

download, install, and run EM3D.  It also contains a brief description of the 
steps used to analyze data from importation to 3D surface rendering. 

2. Tutorial - This is a step-by-step introduction to the EM3D software that 
takes the user through all the steps involved in the successful analysis of 
TEM data. 

3. Appendix – Contains a glossary of terms, acronym list, and a list of figures. 

Most of the images in this document are taken from the Windows version of EM3D. The 
detailed appearance of the graphical user interface varies somewhat from platform-to-
platform and can be adjusted using the LF menu item in the Help>LF drop-down in the 
main visualization window. 

WHEN USING THE OS X VERSION, CHANGING THE DEFAULT LF 
LAYOUT TO JAVA (Help>LF>Java RESOLVES ANY WINDOW 
SIZING ISSUES. 

1.1.2 Syntax of text 
 
Any action you should perform will be bulleted. 
• Read this text. 

 
Items in bold refer to elements of the EM3D User Interface, such as menu items, sliders, 
buttons, etc. . 
For instance, Projection Number slider, File menu item 
The first time a glossary name is used, it is written in bold italics. 
For instance, Voxel. 
EM3D and tutorial related definitions are written in italics, such as State file, Binary file. 

1.2 Some precautions and recommendations 

Although the synthetic dataset that accompanies this tutorial is designed to simulate real EM data, it 
does have some different characteristics. For instance, because of the simplicity of the artificial data 
some objects in the reconstructed volume exhibit unusually prominent reconstruction artifacts. 
Nevertheless, working through the tutorial with this synthetic data will enable the new user to quickly 
learn the features of EM3D. 



The size of a dataset that can be loaded is dependent on the capabilities of the computer and affects the 
speed of operation. Here are some tips for dealing with large datasets: 

• Decimate the projections when they are initially loaded 

• Reconstruct a decimated volume 

• After reconstruction, do not load the projections 

• Decimate the rendering volume 

• Produce a core (sub-volume) from the reconstructed volume. (Currently not 
implemented in the preview release.) 

A three-button mouse is required when using EM3D.  
Set display color quality to “Highest” for PC platforms; on Macintosh, set monitor colors to millions. A 
single large monitor or dual monitors are recommended to accommodate the many windows used with 
EM3D. 

Slight variations in results have been observed on different platforms. 

1.3 Operational features overview 

EM3D provides all the process steps necessary for working with EM tomography data. 

1.3.1 Import raw EM projections 
The starting point for these operations is the raw, unaligned EM projection images 
(Figure 1).  

Note that the images show random spatial offsets from one another. 

 

 
Figure 1: Raw, unaligned EM projection images 

1.3.2 Alignment 
Calculate and remove the image-to-image offsets between individual projections using 
fiducial markers deposited on the sample or contained within the sample. After 
alignment, the collection of images now appears to tilt along a common axis. 

 
Figure 2: Aligned projections 

… … …      
                                               Projections:       72                                       75                                       77                                  78    

 



1.3.3 Reconstruction 
Filtered back-projection converts the aligned projections into a volumetric reconstruction 
of the data. The initial EM3D interface to the volume consists of three 2D views 
corresponding to orthogonal cut planes. 
 

 
Figure 3: Reconstruction 

1.3.4 Combination of dual axis datasets (optional) 
If two orthogonal sets of projections were collected and reconstructed they are combined 
in this step into one volume.  

1.3.5 Segmentation 
Tools are provided to semi-automatically or manually isolate individual structures based 
on their image grayscale density. This process creates volumes-of-interests (VOIs), each 
containing a logically distinct structural component (Figure 4). 
 

 
Figure 4: Segmentation of a synthetic synaptic vesicle 

1.3.6 Model generation and visualization window 
A structural model, usually an iso-density surface, can be created from each volume-of-
interest (VOI). The models can be visualized in 3D renderings, turned on or off, given 
different colors and opacities, etc. 
 



 
Figure 5: Surface model of a synthetic synaptic vesicle (blue), 

 presynaptic membrane (gray) and two filaments (yellow) 

1.3.7 Calculation 
The surface models can be analyzed to measure their spatial uncertainty, proximity to 
neighboring objects, and other quantitative features. The results of these calculations can 
be visualized as a color map overlaid on the rendered surface models. 

1.4 EM3D file format and maintenance 

The EM3D file format consists of two types of data files: 
1. The State file, distinguished by its ‘.xml’ extension: <filename>.xml 

2. The Binary file, distinguished by its ‘.data’ extension: <filename>.data.  

The State file is a relatively small file that contains all the information with respect to the larger Binary 
file such as projection alignment and segmentation data. The Binary file contains the projection and 
volume data. 
These two files are best kept together in named directories. For example, create a directory called EM 
to contain all EM data, e.g., /EM, and a subdirectory that corresponds to a single dataset, e.g., 
/EM/dataset. This directory, in turn, should contain a single Binary file, e.g., dataset1.data, and one, or 
more, State files, e.g., dataset1xml, dataset2.xml, dataset3.xml, etc. By saving changes in the smaller 
State files, and retaining the larger Binary file, disk space is conserved with successive steps in the 
process. The Binary file needs only to be saved after a tilt series is reconstructed into a volume, or if the 
volume is filtered, decimated, or cropped. In the latter case, it is best to create a new directory that, once 
again contains only a single Binary file and its associated state files.  

Caution: All State files contain a reference to the Binary file from which they were 
generated; so changing file names outside of EM3D may result in errors.  
Do not edit the State file by hand.  



To use raw data from the EM, images must first be imported into EM3D and converted to a pair of State 
and Binary files. Current raw data formats supported by EM3D include sets of individual image files or 
an MRC stack file. 

1.5 Downloading EM3D 

The newest release of EM3D is available for download at http://em3d.stanford.edu/downloads.html.  
Login and choose the appropriate download for your system. 
Please also download datasets.zip (for Mac and Windows) or dataset.tar.gz (for Linux). The compressed 
files contain synthetic projections in TIFF format and a dual tilt dataset used in this tutorial as sample 
data. 

1.6 Installing EM3D 

1.6.1 Java 
Java 1.4.2 or higher is needed to run EM3D.  If an appropriate version of Java is not 
installed on your computer, it can be downloaded at 
http://java.sun.com/javase/downloads/index_jdk5.jsp   
If java is not installed on your computer EM3D will NOT run. 
Macintosh regularly offers updates for Java or it can be manually updated from the Apple 
web site. 

1.6.2 Windows XP or greater 
 
• Open the Add or Remove Programs application in the Control Panel folder. 

• Remove previous version(s) of EM3D. 

• Double Click on the em3d.zip file. 

• Double click on the em3d.msi file. 

• The following setup wizard will appear. 

 

 
Figure 6: Windows Install Wizard 



• Press Next> 

 

 
Figure 7: Select program location 

• Choose the location where you want EM3D to Install. 

If more than one user will use EM3D on the computer select Everyone. 

• Press Next > on this screen and the next screen. 

• EM3D will be installed and can be run from the Window’s Start Menu. 

 
 

1.6.3 Linux  
Uncompress the file em3d_2.0_linux.zip. 
• At the Linux prompt type 

  Prompt-> gunzip em3d.tar.gz 
• Extract the tar file into a directory. 

  Prompt-> tar –xvof em3d.tar.gz 
• To run EM3D type 

  Prompt->./linux/em3d 

1.6.4 Mac OS X 
• Download the file from the EM3D web site. 

• The file expands automatically placing the application icon on the desktop. 

• Move the icon to the Applications folder and place an alias in the dock. 



2 Importing and saving datasets 
Data can be initially imported into EM3D in two ways: 

1.  Import individual images (JPEG, BMP, GIF, PNM, PNG, AWT, and TIFF-format) or 

2.  Import a .mrc stack of images typically generated by most data collection software such as FEI 
Tomography or UCSF Tomo. 

Once imported, data is then saved into EM3D format as .xml and .data files. 

Start EM3D and a blank EM3D visualization window opens. 

Note:  Images should be in a 16-bit format. 

2.1 Load TIFF files, Synthetic data set 

The projections of the sample synthetic dataset are in TIFF format. (The dataset can be downloaded 
from em3d.stanford.edu/downloads.)  

• In the EM3D visualization window select File > Import > Images.   

• Navigate to the tiff directory in the EM3D_datasets directory.  

• Select all of the synthA_###.tiff files in the appropriate sequence.  

On Macintosh, UNIX, or Linux platforms select synthA_000.tiff with the left mouse 
button. Scroll to the bottom of the list, hold the <shift> key, and select the last file, 
synthA_150.tiff. All files should be highlighted. 
On Windows platforms it is easiest to use the <ctrl-A> (select all) key. 

• Select OK and the dataset import window will appear (Figure 8). 

2.2 Describe data 

Fill in the Image Import fields so they match the values in Figure 8. 

 
Figure 8: Dataset import window 



Note:  If the Twist Angle is not entered, EM3D will calculate it. The alignment 
will take a little longer for the alignment process to complete.    

• Press OK. 

The center projection number 75 is displayed in the main EM3D window. First, save the imported 
projections, and then explore the features of this window in the EM3D window – projection mode. 

2.3 Save data in the EM3D format 

• From the EM3D menu select File>Save>Binary and State. A file browser 
appears. 

• Navigate to the EM3D distribution directory. 

• Save the file as synthetic_start.  Suffixes will be added automatically 

Note: Both the State and Binary files are saved.  The binary file only needs to be 
saved when the initial projections are loaded and after a reconstruction has been 
performed. 



3  EM3D visualization window  
3.1 Projection mode 

Before we proceed with alignment, we need to learn about the features of the main EM3D window in 
Projections mode. 
The upper-left corner of the EM3D visualization window displays information about the loaded dataset: 
Study, Source, Magnification, and Pixel size, based on the data’s header information or user-entered 
information.  NOTE:  In Mac, these are located in the upper left menu bar instead of the visualization 
window. 

 
Figure 9: Projections in visualization window 

3.1.1 Coordinates 
Move the mouse cursor over the image and the coordinates of the cursor are displayed in 
the Coordinates (nm): field. 

Note that the coordinates shown are the distance of the mouse from the 
center of the projection.  

3.1.2 Measure distances 
A simple measuring tool is available, but not obvious in the main EM3D window.  



• To use the measurement tool, right click the mouse button at the starting point and 
drag the mouse.  The distance in nm from the starting point to the mouse’s current 
location will be displayed in the Distance (nm): field, directly below the 
Coordinates (nm):.  

Note: The measurement is not stored and disappears when the mouse 
button is released. 

 
Figure 10: Measuring tool 

3.1.3 Projection slider 
The Projection slider defaults to the projection that corresponds to the zero-tilt 
projection, in this case “75”. 
• Scroll through the projections by using the Projection slider to determine if any 

projections should be deleted (poor focus, a blank image, etc).  

• Return to projection 75 by clicking the Center button. 

 

3.1.4 Magnification 
The size of the displayed image can be controlled using the zoom list at the lower left 
corner of the window.  
• Enlarge the display to 150%.  

Note that the image window gets horizontal and vertical scroll bars that 
allow navigation through the entire image.   

• Use the Home button to return to the original resolution. 



 

3.1.5 Scaling 
Image scaling is used to set which part of a linear contrast range visually best suits the 
data, e.g., for better fiducial acquisition with noisy data or to better view images during 
segmentation. Scaling changes the visible gray scale range based on the cumulative 
distribution function (CDF), which is shown as a plot versus gray value.  
• To open the Image Scaling window, select Image > Scaling from the main menu 

bar. 

 
Figure 11: Image Scaling 

The red line is the CDF of the image.  If Absolute is selected it is the CDF of all of the 
projections combined; whereas, if Relative is selected it represents the CDF for the 
projection currently displayed in the EM3D visualization window.   
The Min Clip and Max Clip are represented in the graph as the 2 blue lines.  Any pixel 
that has a gray value less than the first blue line will be displayed in the EM3D window 
as black, and any pixel with a gray value higher than the second blue line will be 
displayed as white.  Thus all the contrast that is shown in the EM3D window is assigned 
to the values between the two blue lines. 
For example, if Max Clip is set to .99 then all of the pixels that have gray values in the 
highest 1% will be shown in white.  If Max Clip is set to .85 then the highest 15% of the 
pixels will be displayed in white. Conversely the pixels below Min Clip will be 
displayed black.  
The Invert button reverses the displayed grayscale, generating a negative image that is 
often useful for segmentation.  

Note that the values are only inverted in the display, and not inverted in 
any of the calculations, or in the CDF used to select the contrast range 
(displayed above in red). 

3.1.6 Power Spectrum 
Image > Power Spectrum to view a projection’s power spectrum.  This is particularly 
useful to determine the suitability of any projection before aligning the data set. To scale 
the spectrum, use the Image >Scaling window as described above.  Spectra can also be 
reviewed similar to projections by using the Image>Review feature described in 3.1.7. 



3.1.7 Tilt series animation 
Image > Review creates a movie by scrolling through projections or slices in the EM3D 
visualization window.  The movie’s parameters are defined in the Review control (Figure 
12). 
 

 
Figure 12:  Review Control 

• The Start Projection and Stop Projection determine which projections are used to 
make the movie. 

• Play Start Projection and Play Stop Projection determine the range of slices that 
are shown on the screen, when Review is pressed. 

• Frames Per Second is used to control the speed of the play back after the movie is 
generated. 

• Increment is a way to reduce the amount of memory needed to create the movie, by 
only showing every other projection or every third projection, the size of memory 
needed is reduced. 

• If Bounce is selected the movie loop will play from front to back, then back to front, 
showing a smooth transition.  If Bounce is not selected the movie will loop from the 
last frame back to the first frame. 

• Save will save the pictures exactly as they appear in the movie to JPEG format 
image files. 



4  Alignment 
The raw EM projections are not aligned. Before reconstructing the volume, the image-to-image offsets 
between individual projections must be determined.  This is accomplished by identifying and aligning 
fiducial markers that were either deposited on the sample (such as gold-labeled antibodies) or 
contained within the sample itself. 

EM3D looks for high density fiducial markers for automatic alignment, so additional features can 
interfere with locating these markers and can give erroneous alignments.   

For instance, blank pixel borders surrounding the CCD window, micron marker 
measurements showing on the images, etc. interfere with EM3D’s ability to locate 
alignment fiducials. 

Summary: 

1. Open the Alignment window. 

2.  Adjust the fiducial marker contrast parameters.  

3. Perform either Automatic or Semi-automatic alignment. 

4. Refine the alignment to reach the smallest residual error. 

4.1  Open the projection alignment window 

 
Figure 13: Projection Alignment window 

• From the EM3D visualization window, select Process > Align… to open the 
Projection Alignment window (Figure 13).  



4.2 Fiducial marker contrast-detection parameters  

In this step we are going to set the parameters to locate all potential fiducial markers.  Once we have 
decided on the parameter values, the program identifies all possible fiducial markers throughout the 
projections.  

• Press the Display Markers button at the button of the Alignment window.  

The main EM3D visualization window will display the projections with a yellow 
overlay that indicates the likely positions of fiducial markers. 

 

                          
Figure 14: Display Markers with Threshold set at an appropriate value 

 of 0.35 (left) and too high a value of 0.50 (right) 

 
• Adjust the acquisition parameters so that the majority of the fiducial markers 

visible on the zero-tilt image are marked with the yellow overlay.  

Adjustments can be made by either typing in the text fields (and pressing Enter) or 
by moving the sliders.  
Please read the reference manual for information about choosing parameters.  

Recommended settings for the Synthetic dataset are  
Fiducial Diameter:  5.0 nm 
Twist Angle:   5.0 (generated by the microscope during acquisition)  
Threshold:    0.35 
Min. Projections:  37 (minimum number of projections on which a fiducial  
         Indexes to keep during 
Automatic Alignment) 

 
• After setting the parameters press Display Markers to turn off the overlay in 

order to increase the speed of the following steps. 

 
The Twist Angle is the rotation of the projection tilt axis about the depth axis. When the projections are 
aligned, the tilt axis will be oriented vertically, parallel to the y-axis of the visualization window 
display.   

• If you know the proper twist angle and don’t want the program to adjust it, lock 
it by left clicking on the Twist Angle label.   

A little lock symbol will be displayed next to twist angle, see Figure 15.  



 
Figure 15: Twist Angle Lock 

4.3 Automatic alignment 

• Press Automatic in the Alignment window. 

This is the easiest way to align the projections. 

Automatic performs all of the steps required for alignment.   
1. Automatic first identifies possible fiducial marker on each projection 

(Acquire).  

2. Then Automatic finds the correspondence between potential fiducial 
markers throughout the dataset (Index). 

3.  Finally Automatic iteratively calculates the residual errors for each 
fiducial marker and Deletes the fiducial marker with the highest error.   

                                            
Figure 16: Alignment after using automatic alignment 

Note that the fiducial marker used for the alignment are marked by yellow ‘*’ 
symbols with a red numeral. 

In the Alignment window you find the fiducial marker numbers and their positions, the number of 
projections on which they occur and the error. The total error of the automatic alignment for the 
Synthetic dataset is 0.15 (in pixels). 

In general, the goal is to obtain an alignment where the total RMS error is <1.0 
pixel for every 512 pixels of dimension, so for a 1024x1024 image we strive for an 
error <2.0. 

4.3.1 Fine tune alignment 
In order to fine tune the alignment, 



• Unlock the twist angle by pressing the left mouse button over the Twist Angle label. 

• Then press the Calculate button.  

 
The twist angle will be recalculated and the alignment refined. 
 

 
Figure 17: Results of refined Automatic Alignment 

4.3.2 Visually confirm alignment 
• Press Image > Review in the EM3D visualization window.   

If the alignment is good, all the fiducial markers should move smoothly 
in a horizontal line. (If the alignment is not acceptable please see section 
4.3.3.) 
Note:  Make sure to watch fiducial marker and not the edges of the 
projections.  One suggestion for confirming the alignment is to place the 
edge of a sheet a paper against the screen below a specific fiducial 
marker, and press Review.  The fiducial marker should appear to roll 
smoothly along the paper’s edge, not bounce around. 

When satisfied with the alignment close the Alignment window and save the dataset as 
“synthetic_aligned.xml” by pressing File > Save > Binary and State. The suffixes .xml 
and .data will be added automatically. 
The next section on Trouble shooting automatic alignment is optional, but may prove 
very useful with real data.   

4.3.3 Trouble shooting automatic alignment 
A common cause of automatic alignment failure is that the alignment algorithm can not 
locate a nearby fiducial.  To resolve this problem use a different algorithm,  
• Check Edit > Override in the Alignment Window.  

• Then press Index to use a different algorithm for tracking fiducials through the 
projections. 

• Press Automatic to run the alignment algorithm in a modified way.  If this yields a 
good alignment close the Alignment window and save the data. 

 

Notice that the Twist 
Angle adjusted to 5.4 
degrees and the Total 
Error was reduced 
considerably after 
unlocking the Twist 
Angle. 



Another common cause of alignment failure is the software’s inability to define a 
minimum of two fiducials in each projection.  Projections not marked are noted in the 
window at the lower right portion of the alignment window. Go to the failed projection 
and move to the next projection with at least two fiducials and note what is missing. 
Turn on the Display Markers button and adjust the Fiducial Size and Threshold sliders 
that control the fiducial parameters so the missing fiducials are marked in yellow. When 
all fiducials are found, press Calculate to determine total alignment error. If many 
projections are missing fiducials, it’s best to begin again.  Adjust the Fiducial Size and 
Threshold so more fiducials are marked, turn off the Display Markers and then press 
the Acquire button. This will re-identify all possible fiducial markers.  A message will 
ask if you want to clear the previous alignment. After the new fiducial markers have been 
acquired, repeat the steps for Automatic Alignment. 
If Override and/or adjusting alignment parameters do not yield a satisfactory alignment 
then it is necessary to do semi-automatic alignment. 

4.3.4 Adding or moving individual fiducial markers on a projection 
To add or move a fiducial marker –  
• Highlight the fiducial in the Alignment list. 

 
That fiducial’s marker will turn green on the Projections.   

• Press the Middle mouse button where you want the fiducial marker to be.  If the 
fiducial marker does not move to where you want it, turn on the Display Markers, 
and adjust the fiducial parameters, until a small yellow region appears where you 
want the fiducial marker.  Repress the Middle mouse button. 

• To remove a fiducial marker – Press the right mouse button on or near the fiducial 
marker you want to remove. 

Note: The fiducial marker closest to the mouse click is removed, NOT 
necessarily the fiducial marker that is highlighted. 

4.4 Semi-automatic alignment (Not required for most datasets) 

This section should be skipped for the synthetic data. 
Semi-automatic alignment consists of basically the same series of steps that Automatic alignment uses, 
but it allows more user interaction.  The series of steps for Semi-automatic alignment are: 



1. Identify and remove bad projections. 

2. Acquire – Identify potential fiducial markers 

3. Index – Find correspondence between the identified fiducial markers 

4. Manually add/adjust/remove fiducial markers – Some projections may 
be out of focus so the same parameters that worked for identifying 
fiducial markers on ’in focus’ projections don’t work.  You may need 
to identify the fiducial markers by hand on those slices, using different 
fiducial parameters. 

5. Calculate – The error associated with each fiducial marker 

6. Delete – Remove fiducial markers from the alignment that have high 
error or are not present on a large number of projections 

7. Refine – Repeat the Calculate and Delete steps until an acceptable 
alignment is obtained. 

4.4.1 Identify bad projections 
• Scroll through the projections slider in the EM3D window.  If any are out of focus, 

blank, or in anyway unusable delete them. 

4.4.2 Delete bad projections 
• Set the Projection slider to the bad projection. 

• From the File menu select Delete Projection. 

• Repeat for all bad projections. 

• Once all bad projections have been deleted press Compute CDF. 

 
This step is extremely important. 

• Re-save the binary and state data. 

4.4.3 Acquire fiducials 
• Press the Acquire button in the Alignment window. 

 
If the algorithm is unable to find at least 2 fiducials on any projection it 
will fail for that projection, and you must either add the fiducials by hand 
(see section 4.3.4) or adjust the threshold and/or diameter parameters 
and re-acquire. 

4.4.4 Indexing Fiducials 
This is the process of identifying, or tracking, the same fiducial in multiple projections. 
• Press Index. 

Note, this option is only available if at least 2 fiducials have been 
acquired on all projections. 

• If indexing fails, press Override on the Edit menu, followed by Index again. 



4.4.5 Calculating error and refining fiducial positions 
• Press the Calculate button. 

• Sort the fiducial errors in descending order by pressing the Error column label twice 
in the Alignment window. 

• Select fiducials with high error and press Delete. 

Note, you must leave at least 2 fiducials on all projections, so if you 
delete a fiducial it may reduce the number of fiducials left on some 
projections to less than two.  In this case you should either press Undo 
under the Edit menu, or identify by hand a more accurate fiducial on the 
projections that have been left with less than 2 fiducials. 

• Press Calculate. 

Reconstruction and subsequent segmentations are only as good as the alignment.  Extra time and effort 
used for a good, sub-pixel alignment is well rewarded in the segmentation and rendering steps. 



5  Reconstruction 
After successfully aligning the projections we are ready to reconstruct them into a 3-dimensional 
volume. 

Summary: 

1. Understand the reason for slab reconstruction. 

2. Open the Reconstruction window. 

3. Perform a fast, decimation reconstruction in order to determine the appropriate 
Center and Thickness. 

4. Perform a full-resolution reconstruction. 

5.  Save EM3D data. 

5.1 Understand the reason for slab reconstruction 

There are several things to consider before reconstructing the volume. A tilt-series with projection 
dimensions of 1024x1024 pixels can yield a full size reconstructed volume with dimensions of 
1024x1024x1024 pixels. We know the thickness of our sample is always substantially smaller than the 
width of the projections. In order to reduce the memory and time needed to perform the reconstruction, 
we will only reconstruct a slab of the volume that contains useful data. 
Because the synthetic dataset is small, we can generate a full size (256x256x256 pixels) reconstruction 
to demonstrate the selection of a useful slab of data. 
In Figure 18 we see a series of slices through the volume. The fiducial markers that rest on the top and 
bottom of the sample are visible on slices 75 and 180 respectively; whereas, slices 40 and 216 only 
contain noise.  Thus reconstructing only the slices between the fiducial markers will greatly reduce the 
amount of time and memory used.  

 

       
Figure 18: XY display of slices 40, 75,110,128,149,180,216 

The following is one method to quickly select the appropriate slices for reconstruction. 
Note:  If doing a dual axis reconstruction, the fiducial markers must be included in 
both reconstructed volumes. 

5.2 Open the Reconstruction window 

• Select Process > Reconstruct from the EM3D visualization window.  



The Reconstruction window opens (see Figure 19).  The initial Center corresponds to ½ the number of 
pixels in the projections.  The initial Thickness corresponds to ¼ the number of pixels in the 
projections, and for large datasets, this should represent enough slices to cover the entire volume.  

 

 
Figure 19: Default Reconstruction window 

5.3 Adjust Center and Thickness for dataset 

Our goal in this section is to determine the upper and lower slice limits for reconstructing. 
Note:  The Set Start Slice and Set Stop Slice buttons are inactive. 

For this purpose a low resolution reconstruction is sufficient.  
• Leave the Center and Thickness at their default values. 

•  Move the Decimate slider to 2.  

This will decrease the size of the volume by a factor of 2 in each dimension. For the Synthetic dataset, 
very little decimation is needed, and a 2:1 decimation will adequately reduce time.   

• Move the Sharpness slider to 1.  

These parameters will yield a volume in the Synthetic data set of 128x128x32 pixels (i.e. ½ of 
256x256x64 pixels). 

Note:  For a decimated reconstruction, the Sharpness slider should be set to 1, 
and then returned to 4 or higher for the final reconstruction. 

• Select the Reconstruct button at the bottom left and a Status window opens to 
display the progress of the calculation.  

The visualization window will display the 3 orthogonal center slices of the reconstruction as it builds up 
each projection (Figure 20).  In addition the parameters listed in the upper left of the visualization 
window will show a pixel size of 2.0nm and dimensions of 128x128 pixels after the reconstruction. 

The reconstruction can be stopped at anytime by pressing the Cancel button, 
yielding a partial reconstruction. Partial reconstructions exhibit substantial 
artifacts, but they are often satisfactory for determining the desired thickness of 
the reconstruction, and they save time.  



  
Figure 20: Reconstructed volume, 2:1 decimation (Decimate = 2) 

In addition to the original (x, y) window, the EM3D visualization window displays two additional 
windows, the (x, z) at the bottom and (z, y) on the left. Note that the blue cross hairs are active in all 
windows. Use the left mouse button to ‘slice’ through one of the windows and notice how the other 
windows respond. You can also select the Slice slider button and scroll through the volume using the 
left and right keyboard arrows.  These tools are used extensively in segmenting objects in the volume. 
Turn the crosshairs off or on with Image > Show > Crosshairs. 

5.3.1 Adjust the center and thickness of the volume 
The goal of adjusting the Center and Thickness is to create a reconstruction volume that 
contains only the data of interest.  If a dual axis dataset is being used, all fiducials must 
be present in the final reconstructed volume. 

Note:  Changes to the Thickness and Center will only take effect after 
the Reconstruct button has been pressed. 

The reconstruction using the default Thickness of 64 is too thin because it does not 
reconstruct all the way out to the fiducial markers (in real data the default is usually 
sufficient to cover the entire volume).  
• Move the Thickness slider to130 and perform a second reconstruction, leaving the 

Decimation slider at 2. 

 



 
Figure 21: Reconstruction control for thick, decimated volume 

Figure 21 shows that after the initial reconstruction, the Set Start and Set Stop Slice 
buttons are now active. The reconstructed volume contains all the structures but also 
extends beyond the fiducial markers on the surface (Figure 22). 
 

 
Figure 22: Thick, decimated reconstruction 



5.3.2 Locate the edges of the volume 
• Using the Slice slider button in the main window (or use the left mouse button) move 

the blue horizontal cross hair in the x,z window to the new lower volume edge (slice 
18).  

•  Select the Set Start Slice button in the Reconstruction window.   

• Do the same for the upper edge of the volume (slice 85) and select the Set Slice Stop 
button.   

• Then select Reconstruct.  

 
Dual axis datasets require the inclusion of all fiducial markers in the two 
reconstructed volumes in order to combine properly.  
Dual axis volumes must both be the same size. 

 
Figure 23: Reconstruction Control after adjusting center and thickness 

When satisfied with the volume thickness, generate a full resolution volume. 
 

5.4 Full resolution reconstruction 

• Set Decimation to 1. 

• Return Sharpness to 4. 

• Press Reconstruct. 
When satisfied with this reconstructed volume, name and save both the State and Binary files. 

• In the EM3D window click on File > Save > Binary and State.   

• Save files as  synthetic_recon.  

The reconstructed volume will be automatically saved as synthetic_recon.xml and synthetic_recon.data.  
These new files will be used in the remainder of the tutorial. 

In the future when you load the dataset, you can load just the volume by un-
clicking Load Projections on the File menu before Opening the dataset. 



6  EM3D visualization window –   
    Volume mode 
The EM3D visualization window operates in two modes, Projections and Volume.   Until 
reconstruction is complete, only Projections mode has been available.  However, once reconstruction 
is complete, Volume mode becomes available. The mode display is controlled by a pair of radio 
buttons to the right of the Averaging slider. Projections mode is used to view individual EM 
projection images; when a dataset is initially imported, only this mode is available. Since the dataset is 
now reconstructed, both Volume and Projections mode are available. 

In Volume mode the EM3D visualization window display adds 2 additional graphics panels. This 
allows you to see cuts through the volume at perpendicular (orthogonal) slices (Figure 24). By default, 
the middle slice (slice 50) is displayed in the main (x, y) display panel, while the panel to the left shows 
the (z, y) plane and the panel below shows the (x, z) plane.  

 

 
Figure 24: Volume visualization window mode 

6.1 Navigating through the Volume 

• The blue crosshairs indicate the relative positions of the different slices within 
the volume. The crosshairs can be turned on/off by selecting Image > Show > 
Crosshairs. The crosshairs provide a perspective of objects’ relative positions 
within the volume, and they are useful for finding edges of objects during 
segmentation. 



• Navigate through the volume display using the left mouse button: clicking on 
the (x, y) display moves the transverse (x, z) and (z, y) displays. Similarly, 
clicking on either of the transverse displays changes the slice number of the (x, 
y) display.  

• The (x,y) slice can also be changed using the Slice slider. Display several other 
slices of the volume using the Slice slider. Click on the Center button to go 
back to the slice 50. 

• It is possible to turn on/off the transverse displays by selecting Image > Show > 
Transverse. 

6.2 Averaging slices 

Averaging allows the selection of a different number of adjacent volume slices to be combined (the gray 
value at each x,y pixel is averaged with the gray values in adjacent slices at that same x,y pixel location) 
and displayed as the current slice image. 

• Set the Averaging slider to 5.  

The average gray scale of slices 48 to 52 is displayed in the (x, y) display.  
Averaging is only performed in the (x,y) display. 

• Set the Averaging slider back to 1. 

6.3 Rotating the Volume 

Virtual slices can be formed at any angle through the volume. The rotation sliders allow the user to 
adjust the view in order to see stained objects with better contrast, which is particularly important 
during segmentation. Rotate the volume using the 3 sliders and observe the images. 

• The X Axis is perpendicular to the (z, y) display, positive rotation is clockwise. 

• The Y Axis is perpendicular to the (x, z) display, positive rotation is clockwise. 

• The Z Axis is perpendicular to the main (x, y) display, positive rotation is 
counter-clockwise. 

The cursor position is shown in nm coordinates in the Information in the upper left of the visualization 
window. 

6.4 Filter 

Filtering smoothes (blurs) the data in the image and removes noise. 
• Process > Filter > Average 



  
Figure 25:  Unfiltered and filtered center slice. 

To revert to the original image select Process > Filter > Reset.  To keep the filtered image select 
Process > Filter >Commit.  This will actually replace the volume in memory, and the only way to get 
the original volume back is to reload the dataset.   

For the tutorial we want to reset the filtered image back to the original. 

6.5 Core 

Coring is a way to create a smaller dataset that has only the features of interest.  This is very important 
when your volume is large but the area of interest is small.  By coring you will reduce the amount of 
memory needed to store the volume. 

• Process > Core. 

The following dialog appears. 

 
Figure 26: Core control. 

There are two ways to select the region to core.  One way is to set the slider bars in the control to the 
region of interest.  The second way is to use the right mouse button to define a rectangular region of 
interest in the x,y display (this automatically sets the Start and Stop X and Y coordinates).   Either way,  
determine the z coordinates of the volume by scrolling to the beginning and then the end of the depth of 
the volume to be cored.  Enter those coordinates into the Start Z and Stop Z window and select OK to 
core the volume. 
 
There are two methods to save cored volumes.  After the volume is cored Save > State will retain the 
cored subvolume within the original data set volume.  Save > Binary and State will create a new data 
set with the cored volume only, however it cannot be incorporated back into the original volume. 



For this tutorial we do NOT want to core the volume, so just close the dialog by pressing Cancel. 

6.6 Features that work the same in Projection Mode 

The following features work the same in volume mode as they do for projection mode. 

6.6.1 Magnification 

6.6.2 Animation 

6.6.3 Scaling 



7 Dual Axis Combine 
7.1 General procedure for aligning and reconstructing dual axis datasets 

The previous sections of this tutorial illustrated the reconstruction of a single axis dataset. When 
working with dual axis datasets, you will usually start with 2 MRC files containing 2 sets of projections. 
These projections have first to be aligned and reconstructed individually. Then the 2 resulting volumes 
can be combined to 1 volume.   
To load a dual axis dataset first check the Dual Axis item in the File menu of the visualization window. 
Next import the data; you will be prompted twice to select the filename of the first axis dataset and 
second axis dataset.  

The most accurate dual axis alignments are obtained when fiducial markers are 
on both sides of the section or dispersed throughout the section, as with antibody 
staining methods. 

After a successful import open the Alignment window. A toggle appears for changing between set A 
(first dataset) and set B (second dataset). 

•  Select Set A. 
•  Follow the alignment procedure for the first set of projections. 

The projections of set A are displayed in the visualization window.  
• Select Set B. 

• Scroll through the projections to ensure that they are all good and Delete any 
that are unusable.  

If you Delete any projections make sure to re-calculate the CDF before aligning. 

• Align the second set of projections in the same manner.  

• Save the aligned datasets. 

• Open the Reconstruction window. 

• Check Set A. 
• Perform a reconstruction of A. 

• Save the Binary and State files. 

• Toggle to Set B . 

• Reconstruct set B.  

It is Mandatory that Set A and Set B have the same dimensions in all 3 axes. 

• Save the Binary and State files. 

 

7.2 About the sample dual axis data 

The previous sections of this tutorial illustrated the reconstruction of a single axis dataset. The sample 
dual axis data (part of the downloadable datasets) is a highly decimated real dataset acquired by the 
McMahan Laboratory.  The original projections were acquired at 2048x2048 pixels per projection, and 
have been decimated by a factor of 8 down to 256x256 pixels per projection, resulting in substantial 
blurring of the images.  



7.3 Loading the dual dataset 

• Close and reopen EM3D. 

• File > Open. 

• Select dual_volumes.xml 

7.4 Orienting volume B 

• Select Process > Dual Combine… 

 

 
Figure 27: Dual Combine 

The Set buttons indicate which volume is being displayed in the EM3D visualization window.  By 
toggling between the buttons you can navigate from volume A to volume B. 
The first step in combining the volumes is to get them in roughly the same orientation.  This is 
accomplished by rotating volume B by 90 degrees.  Adjacent to the Set buttons is the Rotate B check 
box.   

• Press Rotate B. 

Volume B can be rotated by either 90 degrees clockwise or counter – clockwise.  
You can chose which direction it rotates through the Rotate menu. Confirm that 
the volumes are in roughly the same orientation by toggling between Set A and B. 

7.5 Identifying fiducial pairs (Indexing) 

Once the volumes are in the same orientation,  
• Select Set A. 

• Press the Auto Index button in the lower right of the Dual Combine window.  

Five columns will appear in the panel, the fiducial number in volume A, the slice on which it occurs, the 
fiducial number in volume B, the slice in volume B where it occurs, and the distance between the 
fiducial markers after an initial match of the volumes.   



In Figure 28 the second row indicates that Fiducial 1 in volume A is centered on slice 22, while the 
same fiducial marker in volume B is labeled number 16 and is centered on slice 24.  After an initial 
cross correlation the fiducial marker is displaced by 2.112nm between the 2 volumes. 

 

 
Figure 28: Auto Indexed 

7.6 Remove invalid pairs and combine 

We want to maximize our knowledge of the volume warping by using as many valid fiducial pairs as 
possible.  For the same reasons, we want to eliminate all false fiducial pairs. Real fiducial markers will 
appear on the top and/or bottom of the sample and not in the middle.  The picture on the left of Figure 
29 shows 2 examples of incorrectly identified fiducial markers (notice these are in the center of the 
sample’s thickness), while the picture on the right of Figure 29 shows correctly identified fiducial 
markers on the bottom of the sample.  This dataset only has fiducial markers on the bottom of the 
sample.   

 



   
Figure 29: False fiducial markers (left) and correct fiducial markers (right) 

The simplest way to remove pairs not on the surface is to sort the fiducial list based on the A Slice 
position (Figure 30).  

• Press the label of the second column to sort the data by A Slice (Figure 30). 

 
Figure 30: Sorted by volume A slice location 

Now look through the volume in the visualization window and determine the slice where the fiducial 
markers end (approximately slice 31).   

• Scroll down the list and highlight all of the fiducial markers with slice positions 
in set A above 31.   

• Press Delete.  

• Press Calculate to regenerate the least squares alignment of the 2 volumes.  

• Double click on the Distance tab to sort the distances in descending order 
(Figure 31).  



Notice that the top fiducial marker has a much higher distance, indicating a miss-
pairing of the fiducial markers between set A and B. 

 
Figure 31:  Sorted by reverse distance 

• Delete the top fiducial marker in the list. 

• Press Calculate.  

• Repeat this step until satisfied that inappropriate pairs have been eliminated. 

• Press Combine to create the volume.  

• Close the Dual Combine window and Save both the binary and state data.  



8  Segmentation and Rendering 
As detailed as the previous seven sections are, loading data, aligning, and reconstructing a new data set 
comprises about 5% of the effort required by EM3D to extract structures of biological interest.  A good 
alignment and quality reconstruction should take less than an hour depending on the ease of the 
alignment step. 

Segmenting individual structures in the reconstructed volume is based on the stain/grayscale densities 
of the various objects. Users define, that is, ‘carve out’ volumes of interest (VOIs) based on these 
grayscales, generating results that are subjective, in nature.  Each VOI should contain a distinct, 
structural component and using automatic, semi-automatic or manual segmentation methods, structures 
of interest can be isolated from the data set volume. Because biological structures often have a range of 
grayscale staining, the user determines and limits the range within the VOI to best represent the 
structure.  

Each segmented object is then the basis for a surface model, which can be displayed, measured, and 
manipulated in 3D. 

EM3D provides tools to measure the accuracy of segmentations (Uncertainty) as well as an 
optimization tool to best represent the segmented structures.   

All segmentations are performed in EM3D’s main visualization X, Y window.  The image in the 
main window can be rotated using the X, Y, and/or Z Axis sliders in order to better orient each object 
for segmentation. 

Please load the reconstructed synthetic dataset for this portion of the tutorial. 

Summary; 

1. Identify a structural component to segment. 

2. Find the central slice of the structural component. 

3. Select a New object. 

4. Name the object. 

5. Select the type of segmentation – Manual or Automatic. If Automatic, choose 
Closed, Isolated, or Pinned. 

6. Segment the slice, either automatically or manually.  

7. Propagate the segmentation throughout the volume, either automatically or manually. 

All Segmentations will vary based on the anchor points chosen with the mouse, for this 
reason, your segmentations may vary slightly from the ones in the tutorial. 

 

 



Note:  Some users invert the objects’ images in the main visualization 
window in order to see the objects for segmentation 
(File>Scaling>Invert check box).  For instance,  

 
Figure 32: Before Inverting 

 

 
Figure 33:  After inverting and scaling adjust 



8.1 How segmentation works 

The way rendering handles manual and automatic objects is very similar 

 
Figure 34: Identify object to segment 

 
Figure 35: Draw initial representation of object 

 
Figure 36: Identify the gray scale range of the object 

Once you know what object you want to segment you 
need to describe it for the computer.   
 
The first step in doing this is to draw a line that 
roughly follows the contours of the object.   This done 
by pressing the middle mouse button to add points 
and the right mouse button to remove points. 
 

The line you draw does not need to be perfect, but 
it should be fairly centered in the object for 
segmenting. 

 

When the Search button is pressed EM3D finds the 
gray scale range within the width around the line you 
drew in the previous step.  It then sets the  minimum 
and maximum gray value sliders to reasonable 
values, and highlightes any voxel within that range in 
red. 

By using the Minimum and Maximum grayscale 
sliders and the Surface width slider you can 
determine which voxels will be used to create the 
anchor lines.  Anchor lines are what EM3D uses to 
represent automatic objects on each slice.  
 
The initial anchor line will be calculated when you 
press Segment. 
 

It is often helpful to reduce both the minimum and 
the maximum sliders, and to select a width that is 
less than the actual width of the object. 



 
Figure 37: Creating first anchor line 

 
Figure 38: Adjust width to cover entire object 

 

 
Figure 39: Initial segmentation 

 

When you press Segment the yellow line with the 
points you selected is replaced with a green line.  The 
green line is the first anchor line.  It is generated by 
finding the best fit of the red voxels.  This is why the 
previous step is so important. 
 
Now that you have described the basic properties of 
your object on one slice, EM3D can follow your 
initial anchor line through subsequent slices by 
pressing the Propagate button. 

Once  the anchor lines are created they are used to 
create a mask of the volume, and only values within a 
radius of the anchor lines will be considered when 
calculating an isosurface.   
 
Once the object has been propagated the red voxels to 
the right no longer represent values within the gray 
scale range, but they represent the surface width.  
Increase the surface width so that it covers the entire 
object, so all appropriate voxels will be considered 
when creating the final surface. 

Once the object is defined by creating the anchors and 
setting the width, the object can be segmented.  This 
is done in the Rendering window.   
 
Select the object from the object list and press Enable.  
An initial iso-surface will be created that probably 
does not represent the data well, as you can see from 
the orange lines in the image. 
 
In order to improve the surface move the iso-surface 
level slider closer to the foot of the CDF, see Figure 
40 



      
Figure 40: Initial iso-surface level (right) and optimized (right) 

 

  
Figure 41: Optimized iso-surface 

 

 
Figure 42: 3D rendering of optimized object. 

8.2 Segmentation modes 

Because the natures of structures observed by EM tomography vary widely, EM3D offers an assortment 
of ways to segment each object.  All object descriptions here refer to the 2D shape in the (x, y) display. 
There are two classes of segmentation available in EM3D, automatic and manual.   

With the isosurface level set to a better value you can 
see how well it follows the edges of the object. 
 
Another way to achieve this effect is to press the Find 
Optimal Isosurface Level button on the Uncertainty 
tab. 



• Automatic segmentation requires the user to define an object on a single slice of 
the volume, than the program finds logical extensions of the object on 
subsequent slices. 

• Manual segmentation is required for any object that is too complex for the 
automatic segmentation to follow, so the user must define the object on each 
slice.   

Below are 3 distinct sub-classes of Automatic segmentation: 
• Closed – Used for objects that are topologically closed, such as the cross section 

of a sphere.  

• Isolated – Used for most ’open-ended’ objects.  The drawback to Isolated 
segmentation is that the algorithm used for propagating an isolated object often 
contracts the anchor line as it propagates. 

• Pinned – Used for ‘open-ended’ objects that have endpoints that occur in the 
same X, Y position in each slice, such as a cell membrane that stretches from 
one edge of the volume to another edge. 

8.3 Automatic closed segmentation 

The four spherical membranes are designed to simulate synaptic vesicles or similar closed structures.  
Closed segmentation is the appropriate method to use for these objects because they can be fit by a 
closed polygon and do not vary substantially from slice to slice. 

• Open the Segmentation window by selecting Process > Segment… from the 
EM3D visualization window. 

 
Figure 43:  Segmentation Window 

8.3.1 Segmenting the upper right vesicle 
• Select Objects -> New object. 

 



 
 Figure 44:  Segmentation File Menu 

A default object name appears, such as Object 1, in the name field.    
• Double click Object 1 and change the name to Vesicle 1. 

Note: All new segmentations default to the Automatic, Closed type. 

• In the visualization window navigate to slice 67 by pressing the Center button. 

• Use Zoom on the EM3D visualization window to enlarge the image by 250%. 

• Use the sliders to navigate through the visualization window, so the upper right 
vesicle is roughly centered in the display (Figure 45). 

• Press the left mouse button in the center of the vesicle, so that the transverse slices 
also depict the desired vesicle (Figure 45). 

• Using the middle mouse button, select several points within the vesicle membrane to 
create a rough anchor path (Figure 45). 

To remove an anchor point press the right mouse button over it. 



 
Figure 45:  Initial segmentation anchor 

Note:  Reduce or increase the size of the anchor points by using the down 
or up buttons on the Anchor Size: 

 
Figure 46: Anchor size adjustment. 

All segmentations of the same object will vary slightly, due to the 
selection of the anchor points. 

• When finished setting the Anchor Points, press Search  

Notice that the area around the yellow anchor line fills with red (Figure 
47b), and the Minimum gray value and Maximum gray value sliders in 
the Segmentation window adjust. 

• Reduce the Maximum gray value slider to a value of 670 (Figure 47c) and press 
Segment (Figure 47d.). 

 
Note:  All numbers are rough guides, since segmentations will vary 
based on anchor points. 



    
a       b c    
   d 
Figure 47: Outlined, Searched area, Reduced Maximum Gray value, and segmented center slice of Vesicle 1. 

• Press Propagate to segment the remaining slices in the vesicle. 

• Press the Home button to return the Zoom to 100%, in order to see the segmentation 
in all 3 windows. 

• Left click inside the segmented vesicle in order to center it in the transverse displays 
(Figure 48). 

  
Figure 48: Initial propagated segmentation of vesicle . 

From the 2 transverse views we see that the propagation worked well for most of the 
vesicle, but needs some adjustment at the top and bottom slices.  

Note:  Your propagation may not look the same depending on the initial 
points chosen. 

 

   
Figure 49: Propagated segmentation with artifact-induced error (left) and after adjustment (right).  



8.3.2 Adjust the propagated segmentation 
•  Use the navigation controls in the visualization window to find the slice where the 

vesicle ends, which should be around slice 99.  

• Now, press the Set Stop button on the Segmentation control window.  This will 
remove the segmentation on slices above 99.  

• Return to a slice near the center of the vesicle (either by left clicking the mouse in a 
transverse plane or by moving the Slice slider). 

• Adjust the Surface width slider until the entire vesicle membrane is covered by the 
red overlay. (approximately 13).  

If you’re segmentation has different errors read the Adjusting a 
propagated segmentation section as a guide to making the appropriate 
changes. 

If possible, the surface width should always be set generously so that the entire object is 
enclosed by the VOI. This permits accurate generation of surface models, discussed in 
the next Section. 

8.4 Adjusting a propagated segmentation 

8.4.1 Setting the start/stop slice 
If the segmentation propagates beyond the edge of the object, then use the Start Slice and 
Stop Slice sliders to identify the range of the object.   

8.4.2 Adjust minimum/maximum gray value 
Usually it is a good idea to reduce the Maximum gray value to only include values that 
correspond to the stained object.  This helps the algorithm follow the line of interest and 
not get attracted to noise. 

8.4.3 Smoothing 
The Smoothing slider determines how fast the curve can deviate.  By increasing the 
smoothing value, you can reduce the likelihood of wild fluctuations in the anchor line.  
Conversely if you have a shape that is changing rapidly, you will need to reduce the 
smoothing to allow the anchor line more flexibility. 

8.4.4  Adjusting the anchor line and re-propagating 
Often a segmentation will propagate smoothly for many slices, but then begin to deviate, 
especially with convoluted membranes.  A good way to approach such a situation is to 
allow the object to propagate.   
• Scroll through the slices to where the segmentation begins to deviate.   

• Press the middle button over the x,y display to shift into Adjust Mode. 

• Adjust the anchor line by adding and removing anchor points with the middle and 
right mouse buttons. 

• Press Segment. 

• Set the Start slice and Stop slice sliders, such that they encompass the region 
through which you wish to propagate the new anchor line. 

•  Press Propagate. 



Example:  Initial Reference slice is 50.  The segmentation starts to go 
awry at 60.  Adjust the segmentation on slice 60 and set the Start Slice to 
60 and the stop slice to an arbitrarily high number. Press Propagate. 

8.4.5 Using a thinner search width 
When objects with similar gray scale are adjacent it is often a good idea to use a smaller 
search width when propagating the segmentation.  This will help the algorithm stay in the 
desired object.  After the propagation is complete increase the width to include the entire 
object. 

8.5 Render Vesicle 1 

• In the EM3D visualization window select Process > Render…. 

 
Figure 50: Process menu on EM3D visualization window Menu 

The Rendering window opens (Figure 51).  
 

 
Figure 51:  Render window 



Notice that Vesicle 1 is listed in red.   

• Select Vesicle 1 in the Objects list. 

• Press the Enable button. 

When a newly segmented object is first enabled or the iso-surface setting is out of range, the following 
message will appear: 

 

 
Figure 52:  Bad Iso-surface warning 

This is because there is initially no iso-surface level associated with an object and a default level needs 
to be established.  

• Select OK and the object will be rendered.   

 

 
Figure 53: Initial rendering of Vesicle 1 

In addition to displaying the 3D iso-surface in the Rendering window, the 2D cross sections of the iso-
surface are shown in the main visualization window. 

Notice in the main visualization window that the red region that defined the 
segmentation volume is replaced with the actual iso-surface, but that the 
segmentation anchor line remains. 

To examine objects in the 3D Rendering window depress the mouse buttons while moving the mouse as 
follows: 

• Left mouse button - Rotate objects. 



• Middle mouse button – Zoom in (down) and Zoom out (up). 

• Right mouse button – Translate in x and y. 

 

 
Figure 54: Vesicle 1 iso-surface overlaid in EM3D visualization window 

• Adjust the iso-surface Level to 680 by moving the Iso-surface Level slider.  

This will create a new model of the vesicle, which more closely follows the contours of the outer 
surface of the membrane, as seen in Figure 55. 
 

 
Figure 55: Vesicle 1 with iso-surface level adjusted to better fit surface 

 



 
• Change the color of the iso-surface by selecting the Color tab in the lower left 

half of the render window.   

• Set Red = 128, Green = 128, Blue = 255.  

• Press Apply or select the Auto Apply check box.  

      
Figure 56: Change iso-surface color 

8.6 Automatic isolated segmentation 

Automatic, isolated segmentation is used for objects such as membranes and filaments.  For example, 
segment the synthetic, rod-like filament connecting the lower left to the upper right vesicle.   

• In the Segmentation window, select Objects > New object. 

•  Name the filament Filament 1. 

• Select the Isolated radio button. 

• Navigate to slice 66 in the EM3D visualization window. 

• Zoom into the image by 250%. 

• Use the middle mouse button to create an initial anchor line (Figure 57a). 

• Press Search (Figure 57b). 

• Reduce the Minimum and Maximum gray sliders (Figure 57c). 

• Press Segment (Figure 57d). 

    
Figure 57: Isolated anchor: a) anchor line, b) searched, c) maximum gray reduced, and d) 

Segmented. 

• Leave the Surface width and smoothing sliders at their default values.   

• Press the Propagate button (Figure 58).  



 
Figure 58: Propagated isolated filament. 

• Examine the segmentation in the EM3D visualization window.   

If you are unsatisfied with the segmentation adjust the propagation using the 
techniques described in Adjusting a propagated segmentation. 

8.7 Render the isolated filament 

In this section you will follow the same basic steps used to render Vesicle 1. 
• Open the Render window. 

• Select Filament from the Objects list. 

• Press Enable. 

• Press the Home button on the top of the panel, so you can see both objects 
(vesicle 1 and isolated filament). 

• Adjust the iso-surface level until the filament is well fit. 

• Make the color of the filament gold using Red = 255, Green = 192, Blue = 64. 

 



 
                 Figure 43: Rendering of vesicle 1 and isolated filament 

   

8.8 Automatic pinned segmentation 

The endpoints of a pinned object occur in the same x,y position throughout all the slices.  This type of 
segmentation works well for objects like the membrane in our synthetic dataset. 

• In the EM3D visualization window press the Home button adjacent to the 
Zoom list. 

• In the Segmentation Window select Objects > New Object. 

• Name the object Membrane. 

• Select Pinned segmentation. 

• Use the middle mouse button to select points for the anchor, and the right mouse 
button to remove points from the anchor line. 

• Press Search. 

• Reduce the Maximum gray value. 

• Press Segment. 

• Press Propagate. 



 
Figure 59: Propagated pinned segmentation 

8.9 Render the membrane 

• Open the Render window. 

The Membrane will be displayed in red in the Objects list. 

• Select membrane from the Objects list. 

•  Press Enable. 

• Press the Home button on the top of the panel, so you can see all of the rendered 
objects. 

Notice that the rendering time has increased.  This is caused by the number of 
polygons in the membrane. In order to reduce the rendering time, decimate the 
membrane surface. 

• Highlight membrane in the Objects list. 

• Move the Surface Decimation slider to 2 under the Main tab. 

• Adjust the Iso-surface Level until the membrane is well fit. 

• Change the Color of the membrane to bright gray using Red = 192, Green = 
192, Blue = 192. 



            
Figure 60: Rendering of Vesicle 1(closed), isolated filament, and membrane (pinned) 

8.10 Manual segmentation 

When structural components have a complex topology or are too noisy for automatic segmentation, it is 
necessary to perform a manual segmentation. In manual segmentation, the goal is to literally define the 
boundaries of a VOI that encloses the structure to be segmented. In the following section a manual 
segmentation will be performed for the small filament that connects the two vesicles on the right-hand 
side of the reconstructed Synthetic volume. 

Note that the major difference between the areas defined by automatic 
segmentation and manual segmentation is that automatic generates a finite region 
around an anchor line on each slice while manual defines the perimeter 
containing the object of interest on each slice. 

•  File > New Object. 

• Select the Manual tab.  

• Name the object manual filament.  

• In the EM3D visualization window navigate to slice 70. 

• Zoom 300% and center Filament 2 in the 3 displays. 

• This time instead of drawing an anchor line in the center of the object we are 
going to draw a closed path around the object. 

Be sure to include the entire object inside the path, because only objects inside the 
outline will be considered. 

• Select the Piecewise radio button.   

Piecewise interpolation connects the anchor points with straight lines (Figure 
61a); whereas, Spline interpolation connects the anchor points with smooth 
curves. 



   
Figure 61a) Draw piecewise manual region, and b) the area included in the manual segmentation. 

• Use the middle mouse button to define anchor points, creating a closed path 
around the object. (Points can be removed by pressing the right mouse button). 
Only a few points are necessary.  

• Press the Segment button. 

The interior of the volume is now marked with a red overlay and the anchor path turns green (Figure 
61b). All points in the interior on this slice have now been added to the VOI for this object. 

• Press the Up button to move to the next slice. The same anchor points that were 
defined on the previous slice appear and can be edited using the mouse as usual. 

• When satisfied with the anchor path, press the Up button again. 

Pressing the Up or Down button is equivalent to pressing the Segment button and 
moving the Slice slider one slice. 

• At the topmost slice containing the object, press Segment.  

• Move to 1 slice below the 1st segmented slice (70) using the using the main 
visualization window tools such as the Slice slider or by pressing the left mouse 
button in a transverse display.  DO NOT use the Down button because it will 
replace the segmentation on each slice with final one.  

• Adjust the anchor points as necessary and press the Down button. 

• Continue editing points as necessary (little editing will be necessary for this 
simple object) and pressing the Down button until the lowest slice containing 
the object is reached; select Segment again. This completes the manual 
segmentation of this object. 

8.11 Rendering a manually segmented object 

• Open the Render window. 

• Select the manual filament in the Objects list. 

• Press Enable. 

• Adjust the iso-surface level until the manual filament is well fit. 

• Make the Color of the filament gold using, Red = 255, Green = 192, Blue = 64. 



8.12 Creating groups 

Sets of logically related objects can be collected into named groups for convenience. To create groups 
use the following steps: 

• In the Objects list, select “isolated filament” and “manual filament”. 

• Select File>Group.  

• Enter the name of the group as “filaments” in the window that appears. 

• The new group will be listed in the Groups list under the Groups tab.  

 
Whenever a group is selected, all of its corresponding members will be selected in 
the Objects list. This permits convenient adjustment of color, iso-surface level, and 
visibility values for multiple objects, it also is useful for doing the calculations on 
multiple objects at the same time. 

8.13 Advanced Rendering 

The EM3D Manual contains information about more advanced features available in the 
Render window.  Some of these features are described in the next Section 8, 
Calculations. 
Other affects worth exploring can be made in the Effects header menu.   

 



9  Calculations 
9.1 Thickness 

These calculations are made from the Process > Render window.   
 
The Thickness tab controls thickness calculation of the selected surface model objects. 

• Select “isolated filament” in the Objects list of the Render window. 

• Press Enable. 

• Select the Thickness tab. 

• Push the Calculate button. 

• Adjust the Minimum and Maximum slider to examine the histogram and 
readouts in nm scale. 

 
Figure 62: Thickness histogram for the isolated filament 

9.2 Spatial uncertainty 

Spatial uncertainty is a measure of the reliability of the iso-surface models. EM3D estimates the spatial 
uncertainty by calculating the gradient scale length, l, in the vicinity of each vertex of the model. The 
scale length is measured, specifically, along the outward normal of the model vertex. This is a measure 
of how rapidly the gray level is changing as one moves away from the model surface at that point – a 
measure of the sharpness of the contrast boundary. This measure is combined with an estimate of 
grayscale uncertainty, σg, to convert grayscale uncertainty to spatial uncertainty: σn = l / σg. 

• First, set a Reference noise level.  Choose an empty area in the data set’s volume 
and segment an object “Reference” by using the Manual segmentation mode and 
segment several slices to get a good representation of background noise.  Enable 
the Reference object and select the “Calculate” button.  Disable the Reference 
object – it’s not needed from here on. 

• Select  “vesicle 1” in the Objects list of the Render window. 



• Press Enable. 

• Select the Uncertainty tab. 

• Push the Calculate button. 

• Adjust the Maximum slider to examine the histogram and readouts in nm scale. 

9.3 Iso-surface optimization 

Iso-surface optimization is designed to quantitatively choose the iso-surface level at which the object is 
best represented based on the Spatial uncertainty.  

• Select “vesicle 1” in the Objects list of the Render window. 

• Press Enable. 

• Note the object’s iso-surface level shown in the Main tab. 

• Select the Uncertainty tab. 

• Press the Find Optimal Iso-surface Level button. 

• Examine the resulting iso-surface in the Render window. 

• View the new iso-surface level in the Main tab. 

9.4 Proximity 

The proximity calculation determines the distance of each point from a reference object to a subject 
object. Any object can be set as the reference.  The distance of each vertex in the object is calculated 
based on the point in the reference closest to it.  The distances are displayed with a color overlay on the 
object. 

• Select “membrane” and “vesicle 1” in the Objects list of the Render window. 

• Press Enable. 

• Select the Proximity tab. 

• Select the “membrane” object (just membrane) from the Objects list. 

• Press Set Reference. 

• Select “vesicle 1” from the Objects list. 

• Press Calculate. 

• Ensure that the Overlay button is checked to observe the results in the object 



10 Appendix  
10.1 Acknowledgments 

 
We would like to acknowledge the following groups whose code is used in this  

program or has provided inspiration: 

Paul Bourke 
Algorithm from “Polygonising a scalar field” by Paul Bourke 

http://astronomy.swin.edu.au/~pbourke/modelling/polygonise 

Takuya Ooura 
“General Purpose FFT (Fast Fourier/Cosine/Sine Transform) Package”  

http://momonga.t.u-tokyo.ac.jp/~ooura/fft.html 

Lee Thomason and Yves Berquin 

“TinyXml”  
http://sourceforge.net/projects/tinyxml 
 
LAPACK 
Linear Algebra PACKage 
http://www.netlib.org/lapack 
 
Fautré, Tanguy 

Tri_stripper code, used to tessellate the 3D models 

http://users.pandora.be/tfautre/softdev/tristripper/ 

Ken Martin, Will Schroeder, and Bill Lorensen 
vtkThinPlateSplineTransfrom algorithm from “VTK”  
http://public.kitware.com/VTK 
Copyright © 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen  

All rights reserved. 

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND 
CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES,INCLUDING, 
BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND 
FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE 
AUTHORS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, 
SPECIAL,EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED 
TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;LOSS OF USE, DATA, OR 
PROFITS; OR BUSINESS INTERRUPTION) 

HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, 
STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN 
ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE 
POSSIBILITY OF SUCH DAMAGE. 



10.2 Glossary 

CCD: A Charge Coupled Device is made up of semiconductors arranged in such a way 
that the electric charge output of one semiconductor charges an adjacent one. A CCD 
camera, for instance, is used to acquire images. 
Cumulative Distribution Function (CDF): The probability that a gray value is less than 
or equal to X. 

 

Decimation: The image or volume size reduction expressed as a log2 exponent, so a 
decimation of  0 means no decimation, full resolution. A decimation of 1 is ½, 
decimation of 2 is 1 / 22 or ¼, decimation of 3 is 1 / 23 or 1/8, etc. 
Fiducial Markers: also referred to as fiducials, colloidal gold beads placed on the 
surface of the TEM sample or incorporated into the sample used to align the projections. 
Intersection: Equivalent to Logical AND, meaning that a point is not added to the new 
region unless all selected VOI’s exist at that point 
Invert: Invert the gray scale of an image to create a negative image. 
Isosurface/isodensity: A region or surface in which the image gray scale is the same, 
similar to topographic lines on a map. 
Projections: Electron micrographs of the individual tilts in the dataset used to reconstruct 
a 3D volume. 
Radio Buttons:  A group of buttons in which exactly one button is selected at a time. 
Signal-to-Noise Ratio:  The ratio between ‘signal’, the desired quantity measured by an 
image, to the ‘noise,’ the random variations in that quantity. In EM tomography, the 
signal is usually the contrast between a structural component and its adjacent 
background, while the noise is a complex function of the EM projection image formation 
and subsequent tomographic processing steps, so SNR is usually estimated empirically 
from the standard deviation of a relatively uniform background portion of the 
reconstructed volume. 
Slices: These are the 2D images that are virtually sliced (interpolated) from the 
reconstructed volume. 
Tessellation: Creation of small triangles that represent a surface for use in surface 
rendering. 
Transverse: The 2 orthogonal views to the x,y plane – the (x,z) and (z, y) planes. 
Topology: Properties of geometric figures or solids that are not changed by stretching or 
bending.  Donuts and picture frames have equivalent topologies. 
Twist Angle:  The rotation of the projection tilt axis about the depth axis 
Union:  The logical OR of two or more objects, i.e. considered true if any object lies in 
the space 
Vertex: A point in 3D space that defines a corner of one or more polygons. 
Volume of interest: A subset of the volume containing defined by the user or an object. 
Voxel: Short for volume-pixel element, the smallest distinguishable cube in a three-
dimensional image. 



10.3 Acronyms 

• CCD: Charged-Coupled Device 

• CDF: Cumulative Distribution Function 

• MIP: Maximum Intensity Projection 

• MPEG: Moving Pictures Experts Group, digital video format 

• MRC stack: Medical Research Council format used to output dataset from the 
microscope 

• nm: nanometer 1x10-9m 

• RMS: root mean square  

• SNR: signal to noise ratio 

• TEM: Transmission Electron Microscope 

• TIFF: Tagged Image File Format 

• VOI: Volume of Interest 
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10.5 Some RGB color combinations 

Color Red  Green Blue 

White 255 255 255 

Black 0 0 0 

Gray 128 128 128 

Red 255 0 0 

Green 0 255 0 

Blue 0 0 255 

Yellow 255 255 0 

Magenta 255 0 255 

Cyan 0 255 255 

Periwinkle 128 128 255 

Gold 255 192 64 

Lime 128 255 128 

Salmon 255 128 128 

Hot Pink 255 64 192 

Neon Green 192 255 64 

Purple 192 64 255 

Turquoise 64 192 255 

Mint 64 255 192 
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