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Preface 
EM3D is a multi-platform application designed to align, reconstruct, segment, model, and 
analyze electron microscope tomography data. EM3D is compatible with UNIX, Macintosh, 
Linux, and Windows. Each dataset consists of a series of two-dimensional transmission 
electron microscope (TEM) images recorded on a CCD camera at regular tilt intervals, for 
instance, ±70º at 1º increments; fiducial markers are visible on each image to facilitate 
subsequent alignment.  

EM3D is being developed in the Laboratory of Dr. U. J. McMahan (Professor of 
Neurobiology and of Structural Biology at Stanford University School of Medicine), and is 
funded by National Institute of Mental Health (MH068065). EM3D software is the joint effort 
between cellular and molecular biologists, who use it daily, and the computational biologists 
and engineers who develop it. The software was initially developed by Dr. David Ress in this 
laboratory and is now being maintained, improved, and extended by  David Yip, Cornelia 
Koch-Stoschek, and Mira Raman. 

This tutorial is designed to instruct a new user in the analysis of EM tomography data.  The 
tutorial takes the user from the beginning stages of importing a small synthetic dataset 
through the entire process of data analysis.   Details on acquiring the EM3D application, 
Synthetic datasets, and IDL Virtual Machine can be found at http://em3d.stanford.edu. 

This release of EM3D has the typical benefits and liabilities of early software releases. 
Nevertheless, major efforts are being made on many levels to make EM3D intuitive, stable, 
and easy to use, as well as to develop new tools and features. EM3D has been used since 1997 
with excellent results in discovering new structures at the 2—3 nm scale, and efforts to 
improve  features and performance continue.  

EM3D is implemented using IDL (Interactive Data Language), which makes use of an 
extensive graphics library as well as numerous tools for rapid applications development. 
Research Systems, Inc., provides a free version of IDL, called IDL Virtual Machine 
(http://www.rsinc.com/idlvm/index.asp), which can run EM3D.  IDL VM is available from 
http://www.rsinc.com/download.  

This software is released expressly for Research Purposes Only. 
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1. Getting Started 
All users should read this section before running EM3D for the first time. 

1.1. An introduction to this text  

1.1.1. Main sections of text 
This text is divided into 3 main sections and an Appendix.   

1. Getting Started - This section contains all the information necessary to download, 
install, and run EM3D.  It also contains a brief description of the steps used to analyze 
data from importation to 3D surface rendering. 

2. Tutorial - This is a step-by-step introduction to the EM3D software that takes the user 
through all the steps involved in the successful analysis of TEM data. 

3. Reference Manual - This section provides more in-depth information about each feature 
in EM3D. 

4. Appendix – Contains a glossary of terms, acronym list, and a list of figures. 

Note: Section numbers in the Tutorial and Manual correspond so that more 
information about a section can easily be found.  For instance, Section 3.1 is the 
Tutorial section on loading data, and section 4.1 is the Manual section on 
loading data. 

Most of the images in this document are taken from the Windows version of EM3D. The 
detailed appearance of the graphical user interface varies somewhat from platform-to-
platform.  

1.1.2. Syntax of text 
Items in bold refer to elements of the EM3D User Interface, such as menu items, sliders, 
buttons, etc.  

 Projection Number slider, File menu 

The first time a glossary name is used, it is written in bold italics. 

 Voxel 

EM3D and tutorial related definitions are written in Italics. 

 State file, Binary file. 
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1.2. Some precautions and recommendations 

Although the synthetic dataset that accompanies this tutorial is designed to simulate real EM 
data, it does have some different characteristics. For instance, because of the simplicity of the 
artificial data some objects in the reconstructed volume exhibit unusually prominent 
reconstruction artifacts. Nevertheless, working through the tutorial with this synthetic data 
will enable the new user to quickly learn the features of EM3D. 

The size of a dataset that can be loaded is dependent on both the capabilities of the computer 
and the memory restrictions of IDL.  For instance we have found that on a Windows machine 
IDL is only capable of allocating up to 1.3GB of memory, regardless of greater hardware 
specifications.  Additionally, IDL is a 32bit program so on any platform the process space 
available to EM3D is less than 3GB, even if the computer has far more memory.  Here are 
some tips for dealing with large datasets: 

• Decimate the projections as they are initially loaded 

• Reconstruct a decimated volume 

• Produce a core (subvolume) from the reconstructed volume 

• After reconstruction, do not load the projections 

• Decimate the rendering volume 

A three-button mouse is very useful when using EM3D. On most platforms, the mouse will 
work properly in its default mode. Alternatively, a one-button mouse can be used, substituting 
ctrl-click (option-click on Macintosh) for the middle mouse button and alt-click (command-
click on Macintosh) for the right mouse button.  

Set display color quality to “Highest” for PC platforms; on Macintosh, set monitor colors to 
millions. A single large monitor or dual monitors are recommended to accommodate the 
many windows used with EM3D. 

Slight variations in results have been observed based on platform and version of IDL used. 

1.3. Operational features overview 

EM3D provides all the process steps necessary for working with EM tomography data. The 
starting point for these operations is the raw, unaligned EM projection images (Figure 1). 
Note that the images show random spatial offsets from one another. 
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1.3.1. Import raw EM projections  

 

Figure 1: Raw, unaligned EM projection images 

… … …      
Projections:                   72                                       75                                       77                                  78    
Green squares mark center of each projection. 
 

1.3.2. Alignment 
Calculate and remove the image-to-image offsets between individual projections using 
fiducial markers deposited on the sample or contained within the sample. After alignment, the 
collection of images now appears to rotate around a common axis. 

 

Figure 2: Aligned projections 

: 

… … … …  
Projections:                   72                                       75                                       77                                  78    
 

1.3.3. Reconstruction 
Filtered back-projection converts the aligned projections into a volumetric reconstruction of 
the data. The initial EM3D interface to the volume consists of three 2D images corresponding 
to orthogonal cut planes. 
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Figure 3: Reconstruction 

1.3.4. Segmentation 
Tools are provided to semi-automatically or manually isolate individual structures based on 
their image grayscale density. This process creates volumes-of-interests (VOIs), each 
containing a logically distinct structural component (Figure 4). 

 

Figure 4: Segmentation of a synthetic synaptic vesicle 

                                                   
(Presynaptic membrane and two filaments are already segmented.) 

1.3.5. Model generation and visualization 
A structural model, usually an isodensity surface, can be created from each volume-of-
interest (VOI). The models can be visualized in 3D renderings, turned on or off, given 
different colors and opacities, etc. 

 

Figure 5: Surface model of a synthetic synaptic vesicle (blue), presynaptic membrane (gray) 
and two filaments (yellow) 

1.3.6. Calculation 
The surface models can be analyzed to measure their spatial uncertainty, proximity to 
neighboring objects, and other quantitative features. The results of these calculations can be 
visualized as a colormap overlaid on the rendered surface models. 

1.4. EM3D file format and maintenance 

The EM3D file format consists of two types of data files: 
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1. The State file, distinguished by its ‘.idl’ extension: <filename>.idl 

2. The Binary file, distinguished by its ‘.data’ extension: <filename>.data.  

The State file is a relatively small file that contains all the changes made with respect to the 
larger Binary file such as projection alignment and segmentation data. The Binary file 
contains the projection and volume data. 

These two files are best kept together in named directories. For example, create a directory 
called EM to contain all EM data, e.g., /EM, and a subdirectory that corresponds to a single 
dataset, e.g., /EM/dataset. This directory, in turn, should contain a single Binary file, e.g., 
dataset1.data, and one, or more, State files, e.g., dataset1.idl, dataset2.idl, dataset3.idl, etc. 
By saving changes in the smaller State files, and retaining the larger Binary file, disk space is 
conserved with successive steps in the process. The Binary file needs only to be saved after a 
tilt series is reconstructed into a volume, or if the volume is filtered, decimated, or cropped. In 
the latter case, it is best to create a new directory that, once again contains only a single 
Binary file and its associated state files.  

Caution: All State files contain a reference to the Binary file from which they 
were generated; so changing file names outside of EM3D will result in errors. 
Do not change file names by changing the file’s icon name. Name or rename 
files only inside EM3D through the File > Save > State or Binary and State 
procedure. 

To use raw data from the EM, images must first be imported into EM3D and converted to a 
pair of State and Binary files. Current raw data formats supported by EM3D include sets of 
individual TIFF files or one, or more, MRC stack files. 

1.5. Downloading EM3D 

The newest release of EM3D is available for download at http://em3d.stanford.edu. 

1.6. Launch EM3D 

1.6.1. Windows platforms  
Double-click the em3d.sav icon or double-click em3d.sav from a file browser. 

Dismiss the IDL VM splash screen by pressing the button marked “click to continue”. 

1.6.2. Macintosh, Cygwin, Linux, and Unix platforms 
From a terminal window launch the IDL virtual machine by entering idl –vm 

Dismiss the IDL VM splash screen, and a file-browser window will open.  

Use the file browser to locate and select the em3d.sav file (Figure 6). 

Note:  If the IDL VM does not start on Mac, Cygwin, and Linux  ensure that X11 
is installed. 
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Figure 6: Startup file-browser window 
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2. Tutorial 
2.1. Importing and saving datasets 

Data recognition by the software is first accomplished by importing your images into EM3D, 
and saving the file in the proper format to an appropriate directory. 

When you start EM3D, a file browser window appears. This will be used during later stages 
of processing to load files already in the EM3D format. To perform raw data import, dismiss 
the file browser window by pressing the Cancel button on its lower right corner.   

Summary 

1. Import TIFF files. 

2. Describe data in the study. 

3. Save in EM3D format. 

2.1.1. Load TIFF files 
Select File > Import > TIFF.   

Make sure the Filters or Files of type field includes *.TIFF 

Navigate to the TIFFs directory in the EM3D distribution software. 

Select all of the syntheticA_###.TIFF  files in the appropriate sequence. On Macintosh, Unix, 
or Linux platforms select syntheticA_000.TIFF with the left mouse button. Scroll to the 
bottom of the list, hold the <shift> key, and select the last file, syntheticA_150.TIFF. All files 
should be highlighted. On Windows platforms it is easiest to use the <ctrl-A> (select all) key. 

Select OK, and the dataset import window will appear (Figure 7). 
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2.1.2. Describe data 

 

Figure 7: Dataset import window 

Fill in the following fields: 

• Source: Synthetic <Enter> 

• Pixel Size: 1.0 <Enter> 

• Start: -75.0 <Enter> (This corresponds to a ±75º rotation with respect to 
the center [zero-tilt] projection.) 

• Increment: 1.0 <Enter> (Projections acquired at 1º intervals) 

Press Generate Tilt Angles. 

Press OK. 

The center projection number 75 is displayed in the EM3D Visualization window. Explore the 
features of this window in the EM3D Visualization window – projection mode, but first save 
the imported projections. 

2.1.3. Save data in EM3D format 
From the EM3D menu select File>Save>Binary and State. A file browser appears. 

Navigate to the EM3D distribution directory. 

Save the file as synthetic_start.idl 

Note: Both the State and Binary files are saved. 
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2.2. EM3D visualization window – projection mode 

Before we proceed with alignment, learn about the features of the EM3D visualization 
window in projection mode. 

The upper-left corner of the Visualization window displays information about the loaded 
dataset: Name, Source, Magnification, and Pixel size, based on the data’s header information 
or user-entered information. 

 

Figure 8: Projections visualization window 

2.2.1. Projection number slider 
The projection number slider is originally set to the zero-tilt projection “75”. 

Scroll through the projections by using the Projection number slider. Now return to 
projection 75 by clicking the Center button. 

2.2.2. Zoom 
The size of the displayed image can be controlled using the Zoom slider at the lower left 
corner of the window. Enlarge the display to 150%. Note that the image window gets 
horizontal and vertical scroll bars that allow navigation through the entire image.  Use the 
Home button to return to the original resolution. 

2.2.3. Exporting images 
Export the non-aligned projections from 50 to 100 as 16 bit TIFF images: 
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2. Specify the Start (50) and the Stop (100) projections using the sliders near 
the top of the window.  

3. Leave the Decimate slider at 0.  

4. Select the Raw button.  

5. Select the TIFF button. 

6. Select the 16-bit button. 

7. Press the Write button.  

8. Select the directory in which to write the files. 

9. Type a prefix for the 51 files to be written, for example “RawProj”. The 
selected projections are saved to 51 TIFF files. A numerical counter is 
automatically appended to every filename. Ex. RawProjA_050.TIFF. 

2.2.4. Tilt series animation 
Review the projections as a tilt-sequence animation. Open Image > Review x,y, the image 
window will be sequentially updated with the entire set of projections. This first review 
sequence serves to create an animation that is then displayed in a new window. This window 
provides extensive control over the animation. On platforms with a full IDL license, an 
MPEG movie can be generated. Click End Animation to close the window.  

If an  error occurs while generating the animation, exit EM3D, restart the 
program, and shrink the size of the graphics window, before retrying. 

2.3. Alignment 

The raw EM projections are not aligned. Before reconstructing a volume the image-to-image 
offsets between individual projections have to be determined, using fiducial markers that are 
either deposited on the sample or contained within the sample itself using gold-labeled 
antibodies. 

Summary 

1. Select Process > Align in the EM3D Visualization window to open the 
Projection Alignment window. 

2. Adjust the fiducial contrast-detection parameters and press the Acquire 
button (see Acquisition). 

3. Review the acquired fiducial positions, make a few adjustments, and press 
the Index button (see Indexing the Fiducial Markers). 

4. Review indexing results, Delete less-frequently occurring fiducials (see 
Review indexing results and Delete fiducials). 

5. Calculate fiducial alignment offsets and residual errors (see Calculating 
alignment offsets). 
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6. Refine the alignment to reach a small residual alignment error (see Refining 
the alignment). 

2.3.1. Open the projection alignment window 

   

Figure 9: Projection Alignment window and initial EM3D Visualization window appearance 

 

From the EM3D Visualization window, select Process > Align to open the Projection 
Alignment window (Figure 9). The main EM3D Visualization window will go into alignment 
mode, displaying the projections with a yellow overlay that indicates the likely positions of 
fiducial markers. 

2.3.2. Acquisition 
In this step we are going to set the parameters to locate all potential fiducials.  Once we have 
decided on parameters, the program identifies all possible fiducials throughout the 
projections. 

Adjust the acquisition parameters so that the majority of the fiducial markers visible on the 
zero-tilt image are marked with the yellow overlay. Adjustments can be made by either 
clicking in the text field or by moving the sliders.  Please read the reference manual section 
3.3 for information about choosing parameters. Recommended settings for the Synthetic 
dataset are  

Fiducial Diameter:  3.0 nm 
Contrast:    0.7  
Threshold:    0.4 

In the Synthetic dataset, with the settings indicated above, the Maximum # of fiducials slider 
will adjust itself to 36. 
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Figure 10: Acquisition of 36 fiducials 

When the parameters have been adjusted, press the Acquire button. A Status window will 
open showing the progress of the acquisition, and the Visualization window will show the 
sequence of projection images from the tilt series, each marked with putative fiducial 
locations.  On most desktop computers, acquisition will take <1 minute for the Synthetic 
dataset. When acquisition is complete, the Visualization display will appear as shown in 
Figure 10. Note that the yellow fiducial marker overlay is now replaced by yellow ‘*’ 
symbols, each marked with a red numeral. These numerals are more-or-less arbitrary from 
projection-to-projection. 

The Twist Angle is the rotation of the projection tilt axis about the depth axis. When the 
projections are aligned, the tilt axis will be oriented vertically, parallel to the y-axis of the 
Visualization display. Normally, this parameter is automatically adjusted during subsequent 
alignment steps to angles as high as 45º.  The twist angle for the Synthetic dataset is small, 
~5º, so it does not need to be adjusted manually. 

2.3.3. Indexing the fiducial markers 
During figucial indexing, 2 things happen: 1) A cross-correlation is done to roughly align the 
images, and 2) each fiducial is tracked through the projections, so that each number will 
correspond to the same fiducial marker in all projections. 

To prepare for indexing, examine the acquired fiducial markers in the zero-tilt projection 
(center) of the Visualization of window. In general, one should now delete poorly positioned 
or false-positive markers.  
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In the Synthetic dataset, the marker labeled 21 in Figure 10 is poorly positioned because the 
associated gold beads are too close together. Delete this marker by positioning the cursor over 
the yellow ‘*’ symbol and pressing the right mouse button. In a real data set it is often not 
necessary to do this because clustered fiducials will often have high error values and will 
subsequently be automatically eliminated. 

  

Figure 11: Align and Visualization windows after indexing 

When the fiducial display has been edited as described, press the Index button on the 
Projection Alignment window.  A Status window will indicate the progress of this 
calculation, which relates the identities of the fiducials locations together across the entire 
sequence of projections. Indexing should take only a few seconds for the Synthetic dataset. 
The indexed fiducial positions are then displayed as a list in the Projection Alignment 
window. The Visualization window display will also change to reflect the approximate offsets 
and indexed fiducial labels calculated during the indexing process. 

2.3.4. Review indexing results and delete fiducials  
Now that we have tracked individual fiducials through the tilt series, we need to assess which 
ones tracked well, and which failed. 

Prepare for the alignment-offset calculation by examining the list of indexed fiducial positions 
in the Projection Alignment window. Each line shows one fiducial position. The number on 
the left side of each line now corresponds to the red index number displayed near each marker 
in the Visualization window. The mean fiducial positions are sorted by the frequency of their 
appearance throughout the projection tilt series, with the fiducials occurring least frequently 
appearing at the top of the list; the precise frequency is the number at the right side of each 
line in the list. For example, fiducial 0 has mean (x, y, z) pixel position (94, 113, 73) and was 
indexed on only 6 projections, while fiducial 10 has mean position (61, 19, 78) and was 
indexed on 142 of the projections. 
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While it is possible to perform calculations with the entire set of fiducials, it is neither 
necessary nor desirable to include the less-frequently occurring fiducials in the calculation, 
since they are not representative of the whole dataset. Ideally, fiducial markers should span 
the entire dataset, but in reality, this rarely occurs. Select the less-frequently occurring 
fiducials in the list, and press the Delete button to remove them. A warning dialog will ask for 
confirmation; select the OK button to initiate the deletion. 

In the Synthetic dataset, select and delete markers 0—9. 

After deletion, the markers will disappear from both the Alignment and Visualization 
windows. 

2.3.5. Calculating alignment offsets  
Now we check the quality of our alignment by calculating the mean error of each fiducial and 
eliminating ones with high error. 

Start by pressing the Calculate button. A Status dialog will open to indicate the progress of 
this calculation. Several iterations or ‘passes’ are frequently necessary when this calculation is 
first performed, particularly if the twist angle is significant. When the calculation is complete, 
the Status window will close and the root-mean-square (RMS) residual alignment error (in 
pixels) for all the fiducials will be displayed near the bottom of the fiducial list (Figure 12). 
The list shows 3D fiducial positions by default; residual errors for each fiducial can also be 
displayed by selecting the Fiducial: Errors radio-button located above the list. 

For the Synthetic dataset, the calculation requires 3 passes and should take less than 2 
minutes. The total alignment error will be 2.27 pixels. In general, the goal is to obtain an 
alignment where the total RMS error is <1.0 pixel. 

   

Figure 12: Alignment and Visualization windows after calculating 
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2.3.6. Refining the alignment 
In many EM projection datasets, the initial alignment will not be satisfactory because the error 
is too high. There are two strategies for refining the alignment to reduce the error: 1) deleting 
fiducials and 2) modifying fiducials.  

Deleting fiducials. The first and simplest approach is to delete fiducials with high residual 
errors from the list. Begin by deleting the fiducials with large error. After deleting the 
fiducials with large error,  press the Calculate button to determine the new alignment and its 
error. Review the resulting individual and total errors and if necessary delete more fiducials 
and recalculate until a satisfactory alignment is obtained.  

During refinement, try to maintain fiducials from different regions of a projection.  In most 
cases a better global alignement can be obtained by keeping widely separated fiducials with 
good error values, rather than by keeping a tight cluster of fiducials with better error numbers. 
Since the projections are not completely rigid bodies, we want to calculate an averaged 
alignment over the entire projection by basing our calculations on samples from as many 
regions of the projection as possible, not just one area.  Otherwise, one area of the projections 
may be well-aligned and other areas may not be. 

For the Synthetic dataset, there is one fiducial with a very large error; fiducial index 15 has an 
x-axis error >12 pixels. Delete this one fiducial and press the Calculate button. The Total 
error now drops to 0.62 pixels, which would be an excellent result for typical EM data. With 
the Synthetic data, however, it is possible to achieve a better result. Delete all fiducials with 
errors greater than 1 pixel, in this case fiducials 10 and 13; this will leave only the ten best 
markers. Press the Calculate button again; after two passes, the total alignment error will be 
0.24 pixels.  

If too many fiducials are deleted, a dialog window will warn that at least two marked fiducials 
per projection are needed for alignment. When this occurs, a Bad Projections field will 
become visible below the fiducial list in the Alignment window, including a drop-down list 
that indicates the projections with less than 2 fiducials. Either revert to the previous marker 
configuration using File > Revert > Single Step, or add the missing fiducials to the offending 
projections using the procedure described below. 

Modifying fiducials. At times, it will be desirable to refine individual fiducial locations on 
projections to improve the alignment. The indexing procedure uses a quasi-2D approach, 
which sometimes causes errors on projections with larger tilt angles (>60). Fiducials positions 
on these projections may therefore need to be added or adjusted interactively. 

To add or adjust a fiducial, select the desired fiducial by left-clicking it in the Alignment 
window list. If the fiducial is visible in the current projection, the corresponding marker will 
change from a yellow ‘*’ to a green ‘+’. Using either the Projection Number slider or the Bad 
Projections drop-down list, select each projection that requires modification. Next, determine 
the location of the desired fiducial marker. Usually, the best strategy is to look at adjacent 
projections on which the desired fiducial has been properly marked. Once the fiducial is 
located, left-click on or near it to mark its position. It is often useful to turn on the fiducial 
marker overlay by selecting the Marker Display: On radio-button. It may also be necessary 
to adjust the Threshold slider so that the marker position is properly indicated by a discrete 
patch of yellow overlay. Repeat this process on additional projections and for additional 
fiducials as needed. To observe the effects of this interactive fiducial marking process, press 
the Calculate button again. 
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For example, fiducial 11 on projection 148 is missing. Select that fiducial in the list and view 
projection 149. Locate the fiducial marked with the green ‘+’, and note its relationship to 
nearby image features. Now, move to projection 148, locate the same fiducial, and add a 
marker using the left mouse button.  

If at any point the alignment goes awry (such as by deleting too many fiducials), previous 
marker configurations can be accessed by using commands located in the File > Revert drop-
down menu: 

• Single Step undoes the most recent deletion and calculation. 

• Calculation removes all previous fiducial deletions and calculations, 
returning the process to its status immediately after the Index step.  

• Indexing returns the process to its status immediately after the Acquire 
step. 

The entire alignment can also be reset to start over using File > Reset. 

At any point in the alignment, a review of the tilt series can be made as a visual check on the 
accuracy of fiducial marking and the quality of the alignment. In the EM3D Visualization 
window, select Image > Review x,y. 

When satisfied with the alignment save it as a new EM3D pair (save Binary and State files); 
use the name “synthetic_aligned.idl”. 

2.4. Reconstruction 

After successfully aligning the data we are ready to reconstruct it into a 3-dimensional 
volume. 

Summary 

1. Open the Reconstruction window. 

2. Estimate z thickness (volume thickness in pixel) and initial z (slice, where 
reconstruction will start) on the basis of the specimen (see Estimate of z 
thickness and the initial z). 

3. Perform a fast (2:1) decimation reconstruction. (see Reconstructing quickly 
a decimated volume).  

4. Adjust initial z and z thickness as needed and recheck reconstruction 
parameters again (see Adjusting “initial z” and “z thickness”) . 

5. Reset Decimation and perform a full-resolution reconstruction (see Full 
Resolution Reconstruction). 

6. Save EM3D data (see Full Resolution Reconstruction). 

2.4.1. Open the Reconstruction window 
Select Process > Reconstruct from the EM3D Visualization window. 
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2.4.2. Estimate of z thickness and the initial z 
There are several things to consider before reconstructing the volume.  The size of the volume 
is directly related to the size of the projections.  A tilt-series with projection dimensions of 
1024x1024 pixels can yield a reconstructed volume with dimensions 1024x1024x1024 pixels.   
We know the thickness of our sample is much smaller than the width of the projections, so to 
reduce time and memory usage, we will only reconstruct a slab of the volume that contains 
data.  The z-axis corresponds to the thickness dimension.  In an ideal example, we could 
assume that the specimen is directly centered in the volume, and ½ the data would be above 
the midline and ½ below.  Since real data sets are less than ideal, let us start by reconstructing 
an additional ~10% on either side of our predicted volume. In order to do this we need to 
convert the slice thickness from nanometers to pixels, using the following equation. 
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In the calculation for zthickness, the value 1.2 accounts for the 10% oversample on either side of 
the specimen.  

Calculation for the synthetic dataset: 

The sample_thickness = 128 nm, resolution = 1 nm, and dimensions = 256×256 pixels, so 
npixels = 256. Therefore zthickness = 1.2 * 128nm / 1nm = 153.6, which can be rounded down to 
150 and zinitial = (256 – 150) / 2 = 53, which we can round down to 50. 

Set the Initial z index slider to: 50 pixels 

Set the z thickness slider to : 150 pixels 

2.4.3. Quickly reconstructing a decimated volume 
The Decimate slider controls the size of the reconstructed volume. Projection images are 
often quite large, e.g., 2048 × 2048 pixels, an 8 MB short-integer image. Consequently, the 
corresponding size of an undecimated reconstructed volume can be very large, e.g., 1 GB for 
a 128 slice reconstruction. Such reconstructions are time consuming to compute, and can tax 
or overwhelm the memory (RAM) capabilities of many desktop computers. The table below 
illustrates the dramatic reduction in image volume (computation time) achieved through 
decimation. 

Decimation 
Level 

In-plane 
dimension 
reduction 

Volume 
reduction 
(Volume) 

0 0  0 

1 ½ 1/8 

2 ¼ 1/64 
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3 1/8 1/512 

 

The reconstructed volume size is indicated by the text field, Volume array size = ## MB, 
located near the middle of the Reconstruction window.  

First, perform fast, decimated reconstructions to determine the Zintital and Zthickness.. 

For the Synthetic dataset, perform a fast 2:1 decimation reconstruction by setting the 
Decimate slider to 1.  

Note that the Volume array size goes from 15 to 2 MB.  

Select the Reconstruct button at the bottom left and a Status window will open to display the 
progress of the calculation. The Visualization window will display the center slice of the 
reconstruction as it builds up each projection.  

A partial reconstruction can be created by pressing the Cancel button on the 
Status window after only a fraction (e.g., half) of the projections have been 
processed. Partial reconstructions exhibit substantial artifacts, but they are 
often satisfactory for determining the desired depth range of the reconstruction, 
and they save time.  

When the reconstruction is complete, the Visualization window will convert to Volume mode 
to display the new reconstruction (see Figure 13).  For a description of the controls in Volume 
mode see 2D Volume Visualization, 
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Figure 13: Reconstructed volume, 2:1 decimation (Decimate = 1) 

The reconstructed Synthetic volume exhibits artifacts common in tomography data. The white 
streaks eminating from the fiducial markers and vesicles are a result of ’shadowing’; one 
structure blocking another behind it. It is also evident on other structures here because of the 
artificially dense nature of the synthetic data. 

In addition to the original (x, y) window, the EM3D Visualization window displays two 
additional windows showing slices that display the z dimension of the reconstructed volume, 
the (x, z) at the bottom and (z, y) on the left. Note that the blue cross hairs are active in all 
windows. Use the left mouse button to ‘slice’ through one of the windows and notice how the 
other windows respond. This is a valuable tool used extensively in segmenting objects in the 
volume. Turn the crosshairs off or on with Image > Show > Crosshairs. 

2.4.4. Adjusting “initial z” and “z thickness” 
The Synthetic data was constructed so that its reconstruction would be perfectly centered in 
the volume cube. Consequently, this reconstruction is nearly ideal – it contains the full 
volume of the sample. However, it is too thick, extending beyond the fiducial markers on the 
surface. To reduce the memory requirements of the final, undecimated volume reconstruction, 
the depth should be reduced. 

To do this, first determine a new setting for the Initial z index. In the (x, z) volume window 
of the EM3D Visualization window, use the cross hair to locate the slice where the gold 
fiducials begin and end. Here, they begin to disappear from the lower part of the volume 
around Slice number 16 [bottom edge of the (x,z) window]. Since this volume is decimated 
2:1, each pixel is 2 nm, so begin the reconstruction at 32 slices (16 * 2) deeper into the 
volume than the original reconstruction start slice; that is, set the Initial z index to 50 + 32 = 
82. 

To determine a new z thickness, use the (x, z) window and determine where the fiducials on 
the top of the volume disappear. This is around slice number 65. The number of slices 
between the lower slice number limit, 16, and the upper slice number limit, 65, is 65 – 16 + 1 
= 50. Again, because of the decimation, multiply by 2, so the new z thickness is 100. 

Enter these new parameters into the Reconstruction window: 

• Initial z index: 82 

• z thickness: 100 

2.4.5. Full resolution reconstruction 
After setting the initial z and z thickness, adjust the Decimation from 1 to 0, and begin a new 
full-resolution reconstruction by selecting the Reconstruct button.  

If satisfied with this reconstructed volume, save both State and Binary. Go to the EM3D 
Visualization window and click on File > Save > Binary and State, Save files as  
synthetic_reco.idl. The reconstructed volume will be automatically saved as 
synthetic_reco.data.  These new files will be used in the remainder of the tutorial. 
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2.5. EM3D visualization window – volume mode 

The EM3D Visualization window operates in two modes, Projections and Volume.   Until 
reconstruction is complete, only Projections mode has been available.  However, once 
reconstruction is complete, Volume mode becomes available. The mode display is controlled 
by a pair of radio buttons to the right of the averaging slider. Projections mode is used to 
view individual EM projection images; when a dataset is initially imported, only this mode is 
available. Since the dataset is now reconstructed, both volume and projections mode are 
available. 

2.5.1. Volume mode 
In Volume mode the EM3D Visualization display adds 2 additional graphics panels., This 
allows you to see cuts through the volume at perpendicular (orthoganol) slices (Figure 14). 
The middle slice (slice 50) is displayed in the main (x, y) display panel, while the panel to the 
left shows the (z, y) plane and the panel below shows the (x, z) plane.  

1. The blue crosshairs indicate the relative positions of the different slices 
within the volume. The crosshairs can be turned on/off  by selecting Show 
> Crosshairs from the Image menu. The crosshairs provide a perspective 
of objects’ relative positions within the volume, and they are useful for 
finding edges of objects during segmentation. 

2. Navigate through the volume display using the left mouse button: clicking 
on the (x, y) display moves the transverse (x, z) and (z, y) displays. 
Similarly, clicking on either of the transverse displays changes the slice 
number of the (x, y) display.  

 

Figure 14: Volume visualization mode 
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3. The (x,y) slice can also be changed using the Slice number slider. Display 
several other slices of the volume using the Slice number slider. Click on 
the Center button to go back to the slice 50. 

4. Averaging allows the selection of a different number of adjacent volume 
slices to be averaged and displayed as the current slice image. Set the 
Averaging slider to 5. The average gray scale of slices 48 to 52 is displayed 
in the (x, y) display.  Averaging is also performed on the two transverse 
displays. 

5. Virtual slices can be formed at any angle through the volume. The rotation 
sliders allow the user to adjust the view in order to see stained objects with 
better contrast, which is particularly important during segmentation. Rotate 
the volume using the 3 sliders and observe the images. 

• The X Axis is perpendicular to the (z, y) display, positive rotation is 
clockwise.. 

• The Y Axis is perpendicular to the (x, z) display, positive rotation is 
clockwise. 

• The Z Axis is perpendicular to the main (x, y) display, positive rotation 
is counter-clockwise. 

The slice images are interpolated directly from the volume. To permanently rotate 
the volume, click on the Apply button. Use File > Restore to revert the volume to 
the original, non-rotated state.  

6. A simple measurement tool is available to measure distances in any of the 
three coordinate windows. Right-click at the beginning point, then move the 
cursor to the end point. A yellow dotted line will show this distance and the 
Distance (nm) will read out just below the Coordinates readout on the left. 
The distance measurement disappears when the right mouse button is 
released. 

Distance measurement does not work when the Segmentation window 
is open. 

7. Scaling is used to adjust the image’s contrast.  
 
Open the Image Scaling Window by selecting Image > Scaling from the 
menu. The gray scale range is shown as a cumulative distribution function.  
Voxels (3D pixel) that have a gray value less than the Min Clip will be 
displayed in black and voxels with gray values above the Max Clip will be 
displayed in white.  All values between the Min Clip and Max Clip will be 
linearly scaled to the full range of gray values.  
 
For example, if both fields are set at 1%, then the darkest 1% and the 
brightest 1% of the pixels in the image will be clipped at black and white, 
respectively, while the remaining 98% of the pixels will be linearly scaled 
between black and white. Increasing both clip values together increases the 
image contrast. 
 
On the lower left corner are two radio buttons, Absolute and Relative. 
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Absolute scales each image based on the range of data values in the entire 
tilt series or volume, while Relative scales each image based only on that 
projection or slice. Relative is the default mode for projections, while 
absolute is the default mode for volume slices. The Invert button reverse 
the grayscale, generating a negative image that is often useful for 
segmentation 

8. In volume mode one can review any of the three orthogonal slice 
orientations by creating animation sequences. Select Image > Review x, y 
and review the volume along the z axis. Select Image > Review x, z and z, 
y to see the animation of the transverse views.  

If a memory error occurs while generating the animation, exit EM3D, 
restart the program, and shrink the size of the graphics window, before 
retrying. 

9. During segmentation, it is often useful to invert the image. Select Image > 
Invert, the grayscale image is reversed and a negative image is displayed. 
Click again on Image > Invert to revert to the original. 

2.6. Segmentation 

Essentially, segmentation defines a volume of interest (VOI) containing a logically distinct 
structural component, allowing the user to ‘carve out’ or isolate individual structures for the 
purpose of surface modelling and 3D visualization. 

If the synthetic dataset has been cored or decimated, the original reconstructed 
volume (with full resolution) should be reloaded for the remainder of this 
tutorial. Reloading is accomplished by exiting EM3D, followed by restarting 
and loading the Synthetic_reco dataset. 

 Open the Segmentation window by selecting Process > Segment… from the EM3D 
Visualization window. 

Summary 

1. Identify a structural component by viewing and navigating through the 
Visualization window in order to choose the optimal volume orientation for 
that object; it may be necessary to rotate the volume. The Synthetic dataset, 
however, is oriented to permit immediate segmentation without adjustment. 

2. Find the central slice of the structural component. 

3. Name the object to segment. 

4. Select the type of segmentation – Manual or Automatic. If Automatic, 
choose Open, Closed, or Isolated. 

5. Segment the slice, either automatically or manually.  

6. Propagate the segmentation throughout the volume, either automatically or 
manually. 
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7. If desired, use a selection of the segmented objects to build a region map 
(see Regional Segmentation). 

2.6.1. Segmentation modes 
Since the nature of structures observed by EM tomography vary widely, EM3D offers an 
assortment of ways to segment each object.  All object descriptions here refer to the 2D shape 
in the (x, y) display. 

There are two classes of segmentation available in EM3D, automatic and manual.   

• Automatic segmentation requires the user to define an object on a single 
slice of the volume, than the program finds logical extensions of the object 
on subsequent slices. 

•   Manual segmentation is required for any object that is too complex for the 
automatic segmentation to follow, so the user must define the object on 
each slice.   

Below are 3 distinct sub-classes of Automatic segmentation 

• Open – Used for ‘open-ended’ objects that stretch from one edge of the 
display to another edge, i.e. an ~planar cell membrane. 

• Closed – Used for objects that are not ’open-ended’, i.e. the cross section of 
~spherical vesicles. 

• Isolated— Also used for ’open-ended’ objects without the constraint of 
being ‘anchored’ to two edges of the image. 

2.6.2. Automatic open segmentation 
To illustrate open segmentation, consider the extensive trilaminar structure in the 
reconstructed volume of the Synthetic dataset, which is designed to have the appearance of a 
presynaptic plasma membrane. Use the slice-navigation tools in the Visualization window to 
examine this membrane. Note that it has an “open” topology, extends throughout the volume, 
and touches 2 edges of the image in each slice. These characteristics make it an ideal 
candidate for Automatic, Open Segmentation. 
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Object  
slider  

Figure 15: Segmentation Window 

1. Using the object slider (Figure 15) in the Segmentation window, select the 
first non-segmented object, this will have the default label “Object 1” and 
Status: clear. Name the new object by entering text to replace the “Object 1” 
label with “Presynaptic Membrane” <Enter>. 

2. If not already selected, choose the Automatic segmentation mode by 
clicking on the tab.  

3. Select the Open radio button if it isn’t already selected.  

4. Choose a reference slice to define the initial anchor points. Use the 
Visualization window navigation controls to find this slice. For the 
Synthetic dataset, any slice near the center of the volume can be used, e.g., 
50. 

5. Define the anchor path. Starting at one end or the other of the membrane, 
use the middle mouse button to define points along its center. At first, 
define only a few points that roughly define the entire length of the 
membrane on this slice; see Figure 16.  The size, shape and colour of the 
anchor points can be defined in the segmentation window: Drawing > 
Change Anchor Mark. 

• Define point: middle mouse button. 

• Remove point: right mouse button. 
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Figure 16: Anchor path for the Synthetic presynaptic membrane, initially and after refinement 
and search. 

6. Refine the anchor path. Add points using the middle mouse button along the 
length of the membrane to more accurately capture the undulations of the 
membrane on this slice. It may be necessary to delete one, or more, of the 
anchor points using the right mouse button. 

7. Press the Search button. Note that the Minimum and Maximum gray 
value sliders are automatically adjusted; values within this gray value range 
are indicated by a red overlay (Figure 16). Sometimes, it is useful to adjust 
these values to improve the segmentation and its propagation, but here it is 
satisfactory to accept the automatically calculated values.  

8. Adjust the Surface width slider to 9 to encourage the segmentation to 
follow the center of the membrane, and not become attracted to opposing 
membranes with similar stain values. Note that the colored overlay narrows 
slightly.  

9. Press the Segment button. The yellow line and points are replaced by a 
continuous green line. This is the segmentation path for this slice. The 
Reference slice: button becomes active and indicates the current slice 
index. 

10. Adjust the segmentation smoothing. To avoid numerical instability during 
propagation of the segmentation path, some additional smoothing is 
necessary. Check the segmentation path. Does the line run accurately along 
the middle of the membrane? To adjust the smoothing,  

• Re-anchor the object (File > Re-anchor). 

• Adjust the segmentation anchor points (if necessary) using the mouse. 

• Adjust the smoothing level, set the Smoothing slider to 10, and the 
Iterations slider to 4. 
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• Re-determine the grayscale range, press Search   

• Re-segment, press Segment.  

• Repeat until the segmentation path accurately follows the middle of the 
membrane. 

11. Adjust the propagation range. The synthetic presynaptic membrane extends 
throughout the volume, but normally it would terminate at the actual 
boundaries of a prepared tissue slice. Moreover, the reconstructed volume 
near the surface may show beam degradation. For illustration, restrict the 
propagation so that it excludes the fiducial markers. Do this by navigating 
upward through the Visualization window from the zero slice until the 
fiducials disappear, then press Set Start (near slice 10). Repeat this process 
on the other side of the volume, navigating downward from the maximum 
slice number until the fiducials again disappear, then press Set Stop (near 
slice 90). 

12. When the controls have values similar to those shown in Figure 17, press 
the Propagate button. The Visualization window will display the results of 
the segmentation on each slice as the propagation proceeds.  

Refreshing the display can take significantamounts of time on slower 
computers, it may be a good idea to reduce the size of the Visualization 
window before initiating propagation.  

 

 

   

Figure 17: Segmentation control window settings and corresponding propagation results. 

13. Use the navigation controls in the Visualization window to examine the 
segmentation results. The green segmentation path should closely follow 
the center of the membrane. 
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14. Adjust the Surface width slider, aiming to find the minimum value for 
which the red overlay (VOI) appears to fully enclose the membrane. For the 
synthetic presynaptic membrane, the final Surface width should be about 
11. If possible, the surface width should always be set generously so that the 
entire object is enclosed by the VOI. This permits accurate generation of 
surface models, as discussed in the Section 2.7. 

Note: the red overlay is not an accurate depiction of the volume-of-interest 
that corresponds to the segmentation on each slice; to save time, the 
overlay is created in 2D only. The actual 3D VOI can be significantly more 
extensive. Use slice planes that are relatively orthogonal to the object to 
assess the coverage of the VOI.  

2.6.3. Automatic closed segmentation 
The four spherical membranes are designed to simulate synaptic vesicles.  Closed 
segmentation is the appropriate method to use for these objects because they can be fit by a 
closed polygon and do not vary substantially from slice to slice. 

1. Move the object slider to Object 2, and name it “Vesicle 1” <Enter>. Select 
the Closed topology button. Segmentation should begin near the middle of 
the volume containing the object (slice 50). 

2. Define a closed anchor path. Starting at any place along the membrane, use 
the middle mouse button to define points along the center of the membrane. 
After the first three points are defined, the path will close. Follow the same 
procedure as before, initially selecting just a few points to roughly define 
the membrane, then adding additional points to refine it.  

3. Press the Search button to display the selected pixel overlay. 

4. Adjust the Surface width slider to 9, so that the entire vesicle membrane is 
marked with the color overlay. 

5. Press the Segment button to generate the segmentation path. Figure 18 
shows the results of these operations. 
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Figure 18: Closed anchor path (left) and resulting segmentation path (right). 

6. Adjust the segmentation smoothing. Check the segmentation path. Does the 
line run along the middle of the object, or is the line perturbed? Adjust the 
smoothing slider, Re-anchor the object (File > Re-anchor), press Search 
and press Segment. Repeat until the segmentation path is in the middle of 
the membrane and even. For the Synthetic dataset the Smoothing to 10, and 
the Iterations slider to 4. 

7. The automatic gray range detection is designed to be fairly generous, often 
it is desirable to adjust the automatic gray range. For example, when the 
SNR (Signal to Noise Ratio) is fairly high, as it is in the Synthetic dataset, it 
is useful to reduce the Maximum gray value (e.g., by 25).  

8. For automatic segmentation, it is not absolutely necessary to establish a 
start and stop slice in advance; propagation will automatically end when the 
specified gray levels are no longer present.  

9. Press the Propagate button and observe the results. When propagation is 
complete, left-click on the center of the vesicle and examine the transverse 
displays. In the direction of smaller slice indices, the propagation 
automatically stopped near the end of the vesicle; in the direction of larger 
slice indices, the segmentation erroneously followed an artifact beyond the 
end of the vesicle (Figure 19). 

 

   

Figure 19: Propagated segmentation with artifact-induced error (left) and after adjustment 
(right).  

10. Adjust the propagated segmentation to correct this problem. Use the 
navigation controls in the Visualization window to find the slice where the 
vesicle ends, which should be around slice 83. Now, press the Set Stop 
button on the Segmentation control window. A query dialog will ask for 
confirmation of this action. Respond affirmatively and the erroneous 
portion of the segmentation will be deleted.  

11. Another approach to this problem is to further reduce the maximum gray 
value and redo the propagation. To do this, select the Re-anchor from the 
File menu. This will return the process to the step immediately before the 
Search button was pressed. Press Search again, and reduce the Maximum 
gray value even more than before, so that the fainter gray values produced 
by artifact are ignored. Press Segment and set the Start / Stop slice sliders 
to their minimum and maximum values, respectively. Press the Propagate 
button and again examine the results. Adjust the Maximum gray value until 
the propagation terminates properly at slice 84.  
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12. Finally, adjust the Surface width slider until the entire structural component 
is enclosed (approximately 15). If possible, the surface width should always 
be set generously so that the entire object is enclosed by the VOI. This 
permits accurate generation of surface models, discussed in the next 
Section. 

Adjusting an Automatic segmentation: 
Sometimes, a single collection of settings is not satisfactory to propagate the 
segmentation throughout the volume of a complex or inhomogeneous structural 
component. In such cases, there are several tools available to adjust the 
segmentation. In addition to the slice-deletion discussed in the example above, 
one can also extend the slice range of a segmentation, which requires defining a 
new anchor path at the slice midpoint of extended range. One can also directly 
edit a segmented slice after propagation by clicking on it with the middle mouse 
button. This click will bring up a query dialog, and, if a positive response is 
selected a new anchor path can be initiated. Adjust parameters, and perform an 
additional segmentation and propagation over a new slice range for this same 
object. 

2.6.4. Automatic isolated segmentation 
This is used for objects such as short membranes in the middle of a volume that don’t ‘close’ 
to the edges, filaments, and so forth. Its use is similar to Open automatic segmentation. 

For example, segment the synthetic, rod-like filament connecting the lower left to the upper 
right vesicle. The range of the filament through the volume is from about slice 43 to 56.  

1. In the Segmentation window, select a new object (Object 3), name it 
Filament 1<Enter>, and select the Isolated topology button.  

2. On slice 48, place a few points along the length of the filament and press 
the Search button. The gray range will automatically adjust to suitable 
values. 

3. Leave the smoothing and propagation-range sliders at their default values:  
Surface width: 11  
Smoothing: 10 
Iterations: 4 

4. Press the Segment button and then the Propagate button and examine the 
results. The propagation will automatically terminate over the slice range of 
37—58.  
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Figure 20: Isolated segmentation, anchor path (left) and initial segmentation (right). 

2.6.5. Manual segmentation 
When structural components have a complex topology or are too noisy for automatic 
segmentation, it is necessary to perform a manual segmentation. In manual segmentation, the 
goal is to literally define the boundaries of a VOI that encloses the structural component. In 
the following section a manual segmentation will be performed for the small filament that 
connects the two vesicles on the right-hand side of the reconstructed Synthetic volume. 

1. Adjust the object slider to find an unused object, e.g., Object 4. Name this 
object Filament 2 <Enter>. Click on the Manual tab to display the manual 
segmentation controls. 

2. Use the Visualization window to navigate to the center of the filament 
connecting the upper-right and lower-right vesicles (about slice 49).  

3. Use the middle mouse button to define anchor points, creating a closed path 
around the object. Only a few points are necessary. The path can be defined 
using either the Spline or Piecewise interpolation-mode radio buttons. 
Spline interpolation connects the anchor points with smooth curves; 
piecewise interpolation connects them with straight lines. Figure 21 shows 
the results using spline interpolation. 

4. Press the Segment button. The interior of the volume is now marked with a 
red overlay and the anchor path turns green (see Figure 21). All points in 
the interior on this slice have now been added to the VOI for this object. 

5. Press the Up button to move to the next slice. The same anchor points that 
were defined on the previous slice appear and can be edited using the mouse 
as usual. 

6. When satisfied with the anchor path, press the Up button again. 

Pressing the Up or Down button is equivalent to pressing the Segment 
button and moving the slider one slice. 

7. At the topmost slice containing the object, select Segment.  
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8. Return to the 1st slice segmented using the Visualization Window 
NavigationTtools; NOT the Down button.  

9. Navigate down one slice, using the Visualization Window Navigation Tools 
; NOT the Down button.  From here repeat steps 5 and 6 using the Down 
button to segment the lower half of the object. 

10. Continue editing points as necessary (little editing will be necessary for this 
simple object) and pressing the Down button until the lowest slice 
containing the object is reached; select Segment again. This completes the 
manual segmentation of this object 

 

  
Figure 21: Points Surrounding Volume (left), Segmented Object (right) 

2.6.6. Regional segmentation 
After several objects have been segmented, it can be useful to divide the volume into regions, 
a set of smaller volumes delineated by boundaries of the existing segmentations. For example, 
in the reconstructed Synthetic volume, based on our current segmentations, one could divide 
the volume into three regions: the extracellular space, the cytoplasm, and the intralumenal 
portion of the vesicle. We will now perform this segmentation: 

1. In the Segmentation control window, press the Disable all button. All of 
the segmentation color overlays will disappear. 

2. Using the object slider, go to the “Presynaptic Membrane” object and click 
on the Slice display: Enable radio button. The segmentation color overlay 
will reappear. Also, adjust the Volume width slider so that its value 
matches the Surface width. Repeat this step for the “Vesicle 1” object. 

3. In the Segmentation control window, select Regions > Map. After some 
brief calculations, the Visualization window display will change to what is 
indicated in Figure 22. 
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Figure 22: Segmented volume after region mapping. 

4. Examine the volume using the Visualization window. A new, graduated 
color overlay divides the volume into three regions or compartments based 
on the two segmentation objects that were Enabled in the slice display: the 
extracellular space is indicated in light blue, the cytoplasm in light red, and 
the intralumenal space of Vesicle 1 in light green. 

5. The region map can be removed by selecting Region > Reset on the 
Segmentation control window. However, the region map will be used later 
to illustrate the generation and visualization of models from regions. For the 
moment, hide the region-map overlay by toggling off Image > Show > 
Regions in the Visualization window.  

6. Clean up. Press the Disable all button to hide all of the segmentation 
overlays. Select File > Close to hide the Segmentation control window. 

7. Save the State file.  From the EM3D Visualization window select File > 
Save > State.  Save the file as synthetic_segmented.idl. 

2.7. Model generation and 3D visualization 

The segmentation process generates a set of volumes-of-interest (VOIs). From each VOI, one 
can create a model of the structure it encloses. Isodensity surface models are usually the most 
informative structural models, and EM3D provides a collection of tools to create and visualize 
these models. The VOIs are themselves volumetric structural models, and EM3D provides 
tools for volume rendering, which can be useful as an adjunct to the isosurface models. 
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Summary 

1. Open the EM3D Rendering window. 

2. Create surface models of selected objects and manipulate these models 
using the mouse as a virtual 3D trackball in the rendering window (see 
Basic Procedures). 

3. Open the Rendering Control window.  

4. Adjust colors and opacities of models (see Rendering control window 
operations) 

5. Adjust isosurface levels to improve the reliability of the models (see 
Adjusting isosurface levels). 

6. Create surface models of regions (see Working with regions). 

7. Group sets of logically related objects and/or regions to groups for 
convenience (see Working with groups). 

Use lighting, clip planes, cut planes, and spin-animation controls to better visualize and 
distinguish the models. 

Open the EM3D Rendering window (RW) by selecting Process >  Render from the EM3D 
Visualization window. The large 3D graphics window will be black and blank – no models 
have yet been generated.  

2.7.1. Basic procedures 
1. Make sure the Objects radio button is selected and the Objects/Regions 

slider is set to 1, the segmentation object previously labeled “Presynaptic 
Membrane.”  

2. Press the Enable button. A Notice window will open briefly, and then a 
surface model of the membrane will be created in the 3D graphics window. 
Note that the button label changes to Disable; pressing it a second time 
would remove the model from the display. 

3. Adjust the Model slider to 2, to the object labeled “Vesicle 1.” Press the 
Enable button again. A surface model of the vesicle will appear on the 
display. 

4. Mouse Controls 

Examine these two models using the interactive mouse controls.  

Rotate: Position the cursor over the 3D graphics window, then depress and hold the 
left mouse button. Move the mouse, while continuing to hold the button down. The 
display will change to a lower-quality rendering. The models will rotate 
interactively, following the mouse movements. Release the mouse button; the 
rendering returns to full quality. 
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Zoom: Hold the middle mouse button down to control the zoom (magnification) of 
the rendered models; outward movements make the models larger, while inward 
movements make the models smaller.  

Translate:  Hold the right mouse button down to control translation of the models.   

5. After the examination is complete, press the Home button that is next to the 
Zoom slider. The display will return to a standard viewing orientation. 

6. This one-by-one generation and examination of models is useful to quickly 
visualize models of new segmentation objects or regions. 

2.7.2. Rendering control window operations  
1. The Rendering Control (RC) window is useful for applying model-

generation and visualization commands to multiple segmentation VOIs. 
Open the Rendering Control window by selecting RW > File > Control….  
As an example, select the other two segmentation objects in the list, 
“Filament 1” and “Filament 2.” Now create models for both of these objects 
by selecting RC > Surface > Enable. 

2. Adjust the color of one model.  Select “Vesicle 1” from the Objects list. If it 
isn’t already selected, select the Color tab to make this control panel visible 
at the bottom of the Rendering Control window. The RGB color sliders are 
all at midrange (128), and the opacity slider is at maximum (255), yielding 
the default mean gray, and fully opaque surface model appearance. To make 
the vesicle blue, adjust the Blue slider to a value of 255. Note that the 
Current color patch shows the original mean-gray color, while the New 
color patch now indicates a blue color. Press the Apply button to change 
the color of the model. 

3. Give the two filaments a gold color. Select both filaments in the Objects 
list. Adjust the Red slider to about 230, the Green slider to about 180, and 
the Blue Slider to 0. Note the color in New color patch. Press the Apply 
button. 

4. Hide the “Presynaptic membrane.” Select it from the Objects list, and then 
select RC > Surface > Hide. The surface model is still present internally, 
but it is removed from the rendered image. 

5. Make the filaments partially transparent. Select both of them in the Objects 
list, and adjust the Opacity slider to a value of 100. Press the Apply button. 
Use the mouse controls in the 3D rendering window to rotate the models so 
that the filaments are in front of the vesicle. The vesicle surface should be 
visible through the filaments. If not, press, the Front button (next to the 
Apply button at the bottom of the Rendering Control window). 

2.7.3. Adjusting isosurface levels 
Surface models have a default value for their isosurface level. This value should be adjusted, 
manually or automatically, to optimize its accuracy and reliability. 

Hide all of the models except “Vesicle 1.” Using the Rendering Control window, select the 
“Presynaptic membrane,” “Filament 1,” and “Filament 2” from the Objects list, and then 
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select RC > Surface > Hide. Press the Home button in the Rendering window so that this 
one model fills the 3D display. 

Manual adjustment of isosurface level is performed using controls on the EM3D Rendering 
window. Use the following steps: 

1. Select the “Vesicle 1” object using the Model slider in EM3D Rendering 
window. 

2. Examine the Isosurface level slider, the text field above it, and the small 
plot window below. The isosurface gray level value can be adjusted using 
any of these three methods: adjust the slider, left-click in the plot window, 
or type a numeric value into the text field. 

3. The current value for the isosurface level is the calculated default for 
Vesicle 1’s segmentation VOI; it should be about 670. The units for 
isosurface level are normalized to the full spectrum of values in the volume, 
so that 0 is the darkest value and 1000 is the lightest. The plot shows the 
cumulative distribution function (CDF) for the entire volume on this 0—
1000 scale. The blue line marks the current value of the isosurface level. 
Normally, the isosurface level should be somewhere on the steep slope of 
the CDF. 

4. Examine the main EM3D Visualization window. Select Image > Show > 
Segmentation and confirm that Objects is checked; select it if not. Click in 
the center of “Vesicle 1” so that its cross-section is visible in all three 
views.  The outlines of the surface model should be visible as blue lines. 
This display provides useful feedback between the 3D models and the 2D 
volume slices. 

5. Adjust the Isosurface level slider downwards in several small steps of 
about 10 units each by using the mouse or by entering numbers into the text 
field pressing <Enter> key on the keyboard. After each change, a new 
surface is created, and the blue line moves leftwards on the plot. Note the 
changes in the models in both the 3D graphics and Visualization windows. 
The optimum value is probably somewhat smaller than the default setting, 
but after 5 or 6 downward adjustments, the surface model will become quite 
sparse and broken. 

6. Return the isosurface level to its default level by entering 670 in the 
Isosurface level text field. 

7. Repeat the sequence of incremental changes, this time moving upwards in 
isosurface level. Again note the changes in the surface model in both the 3D 
graphics and Visualization windows. After 5 or 6 small upward 
adjustments, the model will become increasingly truncated against the 
boundaries of the VOI. 

Automatic optimization adjusts the isosurface level so that it occurs at the sharpest contrast 
boundary for the material within the VOI. Use the following steps: 

1. Use the manual controls to adjust the “Vesicle 1” isosurface level to a 
relatively small value near the lower “tail” of the CDF, e.g., 620. Automatic 
optimization is an iterative search that begins from this value, and 
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convergence is more robust when starting from a smaller (darker) initial 
isosurface level. 

2. In the Rendering Control window, select “Vesicle 1” again from the Objects 
list, and then select RC > Surface > Optimize. 

3. A Notice window will open and display information about the progress of 
the optimization. About a dozen iterations will be necessary to find the 
optimal value for the vesicle model.  

4. After the calculation is complete, the model will be displayed at its optimal 
isosurface level. Examine the results in the 3D and Visualization windows – 
the optimized model should appear to follow the sharpest contrast level. 

5. As another example, optimize both of the synthetic filaments. Select both of 
them in the Objects list, and then select RC > Surface > Optimize. The two 
manual segmentation VOIs will be optimized one-after-the-other. After the 
calculation, the 3D display will update with the new filament models. Note 
that the new models are much better representations of the filaments than 
the default isosurface level model, which exhibited a great deal of noise. 

2.7.4. Working with regions 
Regions are segmentation VOIs derived by compartmentalizing the volume with one, or 
more, object VOIs (see Regional segmentation). Most of the same tools described for the 
object VOIs operate analogously upon region VOIs. Here are some common operations with 
region VOIs. 

1. Examine the Regions list in the Rendering Control window. Three regions 
should be visible with default labels “Region 1,” “Region 2,” and “Region 
3.” The regions are ordered by size, starting with the smallest. From 
inspection of the Regions color overlays in the Visualization window, it is 
possible to conclude that “Region 1,” the smallest, is the intralumenal space 
of “Vesicle 1,” while “Region 2” is the extracellular space, and “Region 3,” 
the largest, is the cytoplasm. 

Note also the first label in the Regions list called “Null”; this region is 
always created, and corresponds to those portions of the volume that were 
outside of the slice range of all of the selected objects. For the Synthetic 
dataset at this point, the “Null” region corresponds to slices 0—9 and 91—
99. 

2. Hide all of the object models by selecting RC > File > Select all  > 
Objects, and then RC > Surface > Hide. 

3. Regions can be dealt with one-by-one using the controls in the EM3D 
Rendering window in much the same fashion as segmentation objects were 
handled.  Begin by selecting the Regions radio button, and then adjust the 
slider so that “Region 1” is selected. Press the Enable button. A small 
spheroidal surface model of the intralumenal space will appear. 

4. Regions can also be dealt with using the Rendering Control window. 
Rename the three regions by either double-clicking each one and naming it 
in turn, or by selecting all three regions and then selecting File > Rename. 
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Change the name of “Region 1” to Intralumenal space,” “Region 2” to 
“Extracellular space,” and “Region 3” to “Cytoplasm.” 

5. Regions can also be optimized. Select “Intralumenal space” from the 
Regions list in the Rendering Control window, then select RC > Surface 
> Optimize. The optimized version of this surface model won’t look much 
different than the default, because this model is formed from the artificial 
noise within the synthetic lumen. 

2.7.5. Working with groups 
Sets of logically related objects and/or regions can be collected into named groups for 
convenience. 

1. In the Rendering Control window, select “Filament 1” and “Filament 2” 
from the Objects list, then select File > Group. A new entry will appear in 
the Groups list called “Group 1.” 

2. Rename this group by double-clicking it; name it “Filaments.” 

3. Regions can also be grouped. Select “Extracellular space” and “Cytoplasm” 
from the Regions list, then again select File > Group. A second entry will 
appear, “Group 2.” 

4. Double-click this group and name it “Large volumes.” 

5. Whenever a group is selected, all of its corresponding members will be 
selected in the Objects and/or Regions lists. This permits convenient 
adjustment of color, visibility, or for the application of calculations as 
described in the next chapter. 

6. To remove a group, rename it with an empty string. Double click each of 
the two groups. In each case highlight the entire text label for the group and 
press the <Backspace> key on the keyboard to clear the label, then press the 
<Enter> key. The groups will disappear from the list as they are removed. 

2.8. Calculation 

Summary 

Spatial uncertainty 

1. Open the Segmentation window. 

2. Create a manual SNR reference object and close the Segmentation 
window. 

3. Open EM3D Rendering and Rendering Control windows. 

4. Select the Uncertainty tab. 

5. Select the previously defined SNR reference in the Objects list and press 
the SNR Reference button. 
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6. Select object(s) and/or regions in their respective lists. 

7. Press the Calculate button. 

8. Examine the results histogram, or create a colormap overlay. 

Thickness 

1. Open EM3D Rendering and Rendering Control windows. 

2. Select the Thickness tab. 

3. Select objects and/or regions in lists. 

4. Adjust parameters if necessary. 

5. Press the Calculate button. 

6. Examine the results histogram, or create a colormap overlay. 

Proximity 

1. Open EM3D Rendering and Rendering Control windows. 

2. Select the Proximity tab. 

3. Select a single reference object or region and press the Reference button. 

4. Select object(s) and/or regions and press the Destination button. 

5. Press the Calculate button. 

6. Examine the results histogram, or create a colormap overlay. 

Automatic Regional Segmentation (ARS) 

1. Open the EM3D Segmentaion Window. 

2. Press Disable All. 

3. Enable the Presynaptic Membrane. 

4. Select Regions > Map. 

5. Close Segmentation window and open the Render Window and the Render 
Controls window. 

6. Select the A.R.S. tab. 

7. Select the Green Region in the Regions: list above. 

8. Press Set Region in the ARS tab. 

9. Set Threshold = 650, Decimation=10, and Minimum Size=100 
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10. Press Calculate. 

11. Enable the RegionGreen Auto Group from the Groups: menu. 

12. Examine the results in the 3D graphics window. 

  

Overlays 

1. Open EM3D Rendering and Rendering Control windows. 

2. Select the Overlay tab. 

3. Select the calculated result from the Overlay pull-down menu. 

4. Select object(s) and/or regions in lists. 

5. Adjust the Minimum / Maximum text fields if necessary. 

6. Press the Apply button. 

7. Examine the results in the 3D graphics window. 

 

2.8.1. Spatial uncertainty 
EM3D estimates spatial uncertainty by calculating the gradient scale length, l, in the vicinity 
of each vertex of the model. The scale length is measured, specifically, along the outward 
normal of the model vertex. This is a measure of how rapidly the gray level is changing as one 
moves away from the model surface at that point – a measure of the sharpness of the contrast 
boundary. This measure is combined with an estimate of grayscale uncertainty, σg, to convert 
grayscale uncertainty to spatial uncertainty: σn = l / σg. 

The steps involved in performing the spatial uncertainty calculation are as follows: 

1. Identify a background region. 

• Examine the volume using the navigation controls in the Visualization 
window. Choose a region corresponding to ‘background,’ a bright and 
uniform area that appears to contain no significant biological material. 
Perform a manual segmentation of that region.  

• Open the Segmentation window Process > Segment…. 

• Choose a distinct, unused Object # such as 999, and label it “SNR 
Reference.”  
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• Select the Manual tab to initialize the segmentation. Select Piecewise 
mode and outline a small portion of the ‘background’ region. Select 
either the Up or Down buttons to create a volume of ‘empty’ space in 
the background area (see Figure 23). It is necessary to select only a few 
volume slices; the goal is select about 5,000—10,000 voxels so that the 
noise estimate is not significantly affected by counting statistics.  
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• On the last slice, press the Segment button to complete the manual 
segmentation.  

• Close the Segmentation window. 

 

Figure 23: Manual segmentation to establish a signal-to-noise ratio reference. 

2. Open the EM3D Rendering and Rendering Control windows. Note that 
the new “SNR Reference” object is now present in the Objects list.  

• Click on this object to select it.  

• Select the Uncertainty tab.  

• Press the SNR Reference button to establish the reference.  

• The Reference object and Reference signal +/– noise fields will update 
appropriately. The reference signal should be approximately 10x larger 
than the reference noise, i.e. the signal-to-noise ratio should be close to 
10. 

2. Once the SNR reference has been established, it becomes possible to 
perform spatial uncertainty calculations on any collection of Objects or 
Regions. To illustrate these calculations, select “Vesicle 1” and “Filament 
1” from the Objects list, and press the Calculate button. 

3. A sequence of Notice dialogs will pop-up as the calculations proceed in 
three steps: 1) a volume mask is created for each VOI; 2) spatial gradients 
are calculated within the VOI; 3) the spatial uncertainty is calculated. After 
each uncertainty calculation, a histogram of uncertainty values is displayed 
in the plot area at the bottom of the Uncertainty tab. 

4. The results of the calculation can be examined by selecting each object or 
region in turn. Select “Filament 1.” The histogram is displayed in the plot 
window, and the minimum, maximum, median, and percentage of “bad” 
values are displayed as text below the plot window. Because of noise, the 
spatial uncertainty calculation inevitably produces a long sparse “tail” of 
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large values, and even some negative values where the gradients point 
inward rather than outward. The latter are flagged as “bad.” At locations 
where large or bad values occur, the surface model is not a reliable 
description of the structure, either because the noise is too large or the 
structural component does not have a sharp boundary at that point. 

5. The results of the spatial uncertainty calculation can be visualized as a 
colormap overlay on each surface model. See Overlays, below. 

Note:  There was an error in a constant used in the proximity calculations 
prior to Version 1.3.  All earlier values should be adjusted by a factor of 2/3 
(0.6667).  All versions from 1.3 onward have this correction applied. 

2.8.2. Proximity 
EM3D calculates precise Euclidian distance maps between model vertices. The calculation is 
exact, so it can be quite time consuming; faster, more approximate results can be obtained by 
selecting the Quick radio button instead of the Exhaustive radio button.  The quick method 
creates a distance, volume map which contains the distance of every voxel in the volume to 
the closest point on the surface of the Reference object.  Thus the same map can be applied to 
multiple objects at virtually no additional expense in time or computing.  The quick method 
suffers from less precision because calculations are done by whole voxels instead of floating 
point Euclidean measures. 

1. Open the Rendering Control window and select the Proximity tab. 

2. Specify the reference model; distance will be calculated with respect to the 
nearest-neighbor vertices on this model. For example, select “Vesicle 1” in 
the Objects list and press the Reference button; the label of this object will 
appear in the Reference model field. 

3. Specify the destination model(s). Nearest-neighbor distances will be 
calculated for each vertex on these models. For example, select the 
“Filament 1” and “Filament 2” models in the Objects list and press the 
Destination button; the labels of these objects will appear in the 
Destination models list. Note that exhaustive proximity calculations can 
take a long time; whereas, quick proximity calculations take approximately 
the same time to calculate for small objects as well as large objects.  In 
addition the quick calculation takes virtually no additional time to calculate 
the proximity of additional objects. 

4. Press the Calculate button. A Status window will open to indicate the 
progress of the calculation. As the proximity calculation for each object is 
completed, its histogram of distance values appears in the plot window in 
the lower part of the Proximity tab. 

5. Examine the results by selecting each model in the Objects or Regions lists. 
For example, select first “Filament 1,” then “Filament 2.” The histogram 
and statistical information (minimum, maximum, median) will appear for 
each model as it is selected. 

6. The results of the proximity calculation can be visualized as a colormap 
overlay on each surface model. See Overlays, below. 
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2.8.3. Thickness 
EM3D calculates thickness at each vertex by searching along the direction of the inward 
surface normal for opposing vertices that fall within a specified angular aperture. The 
“thickness” is defined as the mean distance between these vertices and the original vertex. 
This calculation can be time consuming for extensive surfaces; faster, more approximate 
results can be obtained by increasing the decimation level of the surface models. 

1. Open the Rendering Control window and select the Thickness tab. 

2. Choose model(s) for the calculation by selecting from the Objects or 
Regions list. For example, select “Vesicle 1”.  Warning: it takes a very long 
time to perform calculations for the “Presynaptic membrane” and “Vesicle 
1”. 

3. The Minimum and Maximum Thickness Sliders have 2 purposes, 1) to 
limit the range of values considered in calculating the Thickness, and 2) to 
isolate values once the Thickness has been calculated.  For instance, with a 
Vesicle that has a membrane thickness of 7nm and a diameter of 60nm, you 
can calculate either by setting the Minimum and Maximum Slider values 
correctly.  To get the diameter of the Vesicle leave the Slider values at 0 and 
99.  To get the membrane thickness set the slider values at 3 and 15.  By 
limiting the slider values to distances roughly half to twice the expected 
thickness you will only be considering points in the right range. 

4. Press the Calculate button. A Status window will open to indicate the 
progress of the calculation. As the thickness calculation is completed, its 
histogram appears in the plot window in the lower part of the Thickness 
tab. 

5. Adjust the Minimum and Maximum Thickness Sliders to identify only 
reasonable points.  For instance choose values around the histogram peak 
you are interested in. 

6. Note that the statistical information (minimum, maximum, median) will 
appear at the bottom, these values will only be calculated for values within 
the Min-max range shown on the sliders. 

7. The result of the thickness calculation can be visualized as a colormap 
overlay on a surface model. See Overlays below. 

2.8.4. Overlays  
The results of any of the three calculations described above, uncertainty, proximity, and 
thickness, can be visualized on its corresponding surface model as a colormap overlay. The 
overlay represents the numerical value of the calculation at each vertex as a specific color. 

1. Open the Rendering Control window and select the Overlay tab. 

2. Near the top of this tab is the Overlay pull-down menu. (If this menu 
displays “NONE”, perform the tutorial calculations described in the 
previous three subsections (Uncertainty, Proximity, and Thickness); the 
following assumes this has been done.) Select “Uncertainty” from this 
menu. 
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3. In the Rendering Control window, select File > Select all > Objects; all of 
the object models will be highlighted. 

4. The Available models list will display that subset of the selected models 
for which Uncertainty data is available. In this case, “Obj: Vesicle1” and 
“Obj: Filament 1” appear, corresponding to the two objects for which 
uncertainty was previously calculated. 

5. Below the list are text fields labeled Minimum and Maximum. By default, 
these fields are set to the actual minimum and maximum values for the 
selected collection of overlay data; these values are also shown for 
reference as labels just to the right of the text fields. Presently, the minimum 
value should be small, <1, while the maximum value should be a large 
number, ~104. 

6. To display a map of uncertainty that spans the range 0—5 nm, select the 
text in the Minimum field and enter 0 (zero), then press <Enter> on the 
keyboard. In a similar fashion, enter the number 5 into the Maximum field. 
Press the Apply button near the bottom of the tab. 

7. Examine the 3D graphics window (Error! Reference source not found.). 
A colormap overlay is now visible on the simulated vesicle and one of the 
filaments. The color bar near the bottom of the Overlay tab indicates the 
mapping between the colors and the uncertainty values; the bar is set so that 
it spans the range 0—5 nm. The majority of the vesicle and filament 
surfaces show a dark blue color indicating small uncertainty values; here the 
model surface is interpolated through regions where the gradient scale 
length was very small, so the model’s vertex locations are insensitive to 
grayscale noise in the volume and therefore very reliable. There are a few 
punctuate regions of larger spatial uncertainty near the equator of the 
simulated vesicle because the larger amount of surface texture here 
increased the gradient scale length, making the model vertex locations in 
these more sensitive to grayscale noise in the volume and therefore less 
reliable. 
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Figure 24: Spatial uncertainty overlays 

8. Examine the EM3D Rendering window. Use the Model slider to select 
“Vesicle 1.” Information about the spatial uncertainty overlay will now 
appear near the lower left corner of the window. This feature provides 
convenient information about whatever overlay has been applied to a 
particular model. 

9. Many colormaps are available, and each can be customized in various ways. 
Click the left mouse button directly on the color bar to bring up a dialog 
window with an extensive list of colormaps and tools for their individual 
customization (see Figure 25). For example, select the “Rainbow” colormap 
from the list, then press the Done button. The new colormap will now 
appear on the colorbar in the Overlay tab of the Rendering Control 
window. Press the Apply button to display the new colormap on the surface 
models. 

10. The Bad value patch below the color bar can be used to mark such values 
with a distinctive color. By default, the patch shows black (RGB value = {0, 
0, 0}). With this setting, bad values are not colormapped; they remain at 
whatever color was set for the model before the overlay was applied. 
Change this setting to mark the bad values. For example, in the Rendering 
Control window, select only “Filament 1,” then click the left mouse button 
on the Bad value patch. A small dialog will pop up with a text field 
showing the current settings. Change these values to “255, 255, 255” and 
press the <Enter> key on the keyboard. The Bad value patch will now turn 
white. Press the Apply button to apply this white marking to the vertices 
with bad spatial uncertainty values on model. 
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Figure 25: Color-map dialog window 

11. Using the mouse controls in the 3D graphics window, rotate the models so 
that the tip of “Filament 1” distal to the vesicle is visible. This tip will have 
several white vertices (see Figure 26). This region of the model cuts into 
another synthetic vesicle, so the gradients in this region are inverted, 
creating “bad values” by definition. 

 

Figure 26: Marking bad values 
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12. It is also possible to remove colormap overlays from models. On the 
Overlay tab of the Rendering Control window, press the Remove button 
to remove the overlay from “Filament 1.” On the EM3D Rendering 
window, press the Home button to return the display to its default 
viewpoint. 

13. Any of the other calculated quantities can also be rendered as an overlay. In 
the Overlays tab of the Rendering Control window, select “Proximity” 
from the pull down menu. Press the Apply button. A color-map overlay will 
appear upon “Filament 1” that indicates the proximity of its vertices to the 
vesicle. 

14. Select “Thickness” from the Overlays pull-down menu. In the Objects list, 
select “Filament 2.” Click on the color bar, and use the color bar dialog to 
change the color bar to “Blue-Red.” Press the Apply button to visualize the 
thickness values on “Filament 2.” Use the mouse controls in the 3D 
graphics window to examine the results (see Figure 27). 

 

Figure 27: Color overlays showing spatial uncertainty on the vesicle, proximity to the vesicle 
on Filament 1, and thickness on Filament 2. 
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3. Reference Manual  
3.1. Loading data 

To use EM3D, raw data from the EM must first be imported into EM3D. The imported data 
then will be saved in an EM3D specific format (.idl and .data files). Current raw data formats 
include sets of individual TIFF files or multiple MRC stack files.  

3.1.1. Opening EM3D datasets 
Select File > Open from the menu. A file browser opens. Select the State file that corresponds 
to the dataset.  

3.1.2. Importing raw EM projection images and reconstructed volumes into 
EM3D 
To access the file importation features, press Cancel on the initial File open Dialog. This will 
reveal the main EM3D Visualization window. Use the File menu to access the import 
features. 

3.1.3. Importing TIFF projection images  
Select File > Import > TIFF from the EM3D Visualization window.  

Locate the directory containing the TIFF files. On all platforms except Windows, select all the 
images by clicking on the first file, then the last file while pressing the shift key. On Windows 
platforms, reverse the procedure by first clicking on the last file in the sequence, then the first, 
or press ctrl+A to select all files. Press OK to start the file import process. 

Because TIFF images have no header information regarding tilt, magnification, pixel size, 
etc., EM3D will pop up the Specify Parameters window to allow this information to be 
specified (Figure 28). 

Using EM3D 

 
 

53



 

 

Figure 28: Specify parameters for loading raw EM  projection data 

3.1.4. Importing MRC stack files 
Select File > Import > MRC Stack from the EM3D Visualization window. A file browser 
window will open; use it to select one MRC Stack files. After EM3D loads the MRC files, it 
will open the Specify Parameters window. Because the MRC files include header 
information, generally only Source information needs to be entered, although the other fields 
can be edited if necessary (see Figure 28). 

EM3D explicitly supports only the UCSF version of the MRC file format. If you 
have problems loading your MRC stack, convert the data stack to a series of 
TIFF files and import these in EM3D. 

3.1.5. Saving the imported data 
When projections are loaded, the zero degree tilt will appear in the EM3D Visualization 
window. Save the dataset with a new name (File > Save > Binary and State) to generate new 
.idl and .data files. 

3.1.6. Importing Reconstructed Volumes from TIFF images 
It is possible to import already reconstructed volumes into EM3D.  The volume must be saved 
as a series of TIFF images with 16 bit precision.   
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Select File > Import > TIFF from the EM3D Visualization window.  

Locate the directory containing the TIFF files. On all platforms except Windows, select all the 
images by clicking on the first file, then the last file while pressing the shift key. On Windows 
platforms, reverse the procedure by first clicking on the last file in the sequence, then the first, 
or press ctrl+A to select all files. Press OK to start the file import process. 

The Specify Parameters window will appear.  The default Type for TIFF images is 
Projection, so select the Volume radio button to the right of the file list.  The parameters to 
specify will change from Figure 28 to Figure 30.  Enter the appropriate data and press OK. 

 

Figure 29:  Importing Reconstructed Volume from TIFF
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3.2. EM3D visualization window 

3.2.1. Overview 

 

 

Figure 30: EM3D visualization window, projection and volume modes 

The upper-left corner of the EM3D Visualization window displays information unique to the 
dataset such as its name, source (produced by which computer or microscope), magnification, 
and pixel size, based on the data’s header information or user-entered information. The EM3D 
Visualization window operates in two modes, Projections and Volume, controlled by the pair 
of radio buttons at the left-center of the window. The size of the displayed image can be 
controlled using the Zoom slider at the lower left corner of the window. Zooming can be 
particularly useful during segmentation (described below); note that large zoom factors will 
significantly slow the image display update. 

Projections mode is used to view individual EM projection images. When a dataset is 
initially imported, only this mode is available. The Projection number slider, just left of the 
mode-control buttons, controls which tilt-angle projection is displayed. The tilt angle and 
cursor pixel coordinates are displayed just above the slider.  

Note: For Macintosh and UNIX/LINUX platforms, all sliders in EM3D can be 
controlled with the keyboard arrows. Select the slider and use the left arrow(←) 
to decrease, and right arrow (→) to increase values.  

Volume mode is used to view virtual slices through a reconstructed volume.  
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The following coordinate system will be used to describe the volume. The (x, y) 
plane corresponds to original zero-tilt plane of the EM images, and after 
alignment, the y-axis is the tilt axis. The z-axis is the reconstructed depth axis. 

Volume mode becomes available only after a volume has been reconstructed. The display 
windows take on a different character in volume mode, showing three orthogonal slices 
through the volume, with blue crosshairs indicating the relative positions of the different 
slices within the volume. The crosshairs provide a reference for objects’ relative positions 
within the volume, and they are useful for finding edges of objects during segmentation. One 
can navigate the volume display using the left mouse button: clicking on the (x, y) display 
moves the transverse (x, z) and (z, y) displays. Similarly, clicking on either of the transverse 
displays changes the slice number of the (x, y) display as well as the position of the other 
transverse display.  

Several additional controls, which are grayed out and inactive in Projection mode, become 
available in Volume mode. Averaging allows the selection of adjacent volume slices to 
average with the current slice to form a smoothed slice (for display purposes only).  

Virtual slices can be formed at any angle through the volume, as controlled by three sliders: 

• X Axis rotates about the x-axis [in the (z, y) plane] 

• Y Axis rotates about the y-axis [in the (x, z) plane] 

• Z Axis rotates about the z-axis [in the (x, y) plane 

These slice images are interpolated directly from the volume. To permanently rotate the 
volume, click on the Apply button. These rotation tools allow the user to adjust the view in 
order to see structural components with better contrast, which is particularly important during 
segmentation.  

 
Note: The segmentation and alignment windows must both be closed to rotate 
the volume. 

A simple measurement tool is available to measure distances in any of the three coordinate 
windows. Right-click at the beginning point, then move the cursor to the end point. A yellow 
dotted line will show this distance and the Distance (nm) field will read out just below the 
Coordinates readout on the left. The distance measurement disappears when the right mouse 
button is released. 

The three main pull down menus of the EM3D Visualization window are: File, Image, and 
Process; these are each described in detail in the next chapters. 

3.2.2. The file menu 
Open is used to open .idl/.data files. It is grayed out after a dataset is loaded, to load a new 
dataset, one must exit and restart EM3D. 

Import is used to import raw data files, e.g. TIFF, MRC stack, or volume projections from 
other sources. It is also grayed out after a dataset is loaded. 
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Restore is used to revert to the original reconstructed volume data after changes such as 
rotation or smoothing are made, that is, Restore returns the data to the original, non-modified 
state. It operates only in volume mode. 

Restore doesn’t work if you want to undo a decimation or core. These are irreversible steps. If 
not satisfied with decimation or core operations, quit EM3D without saving. 

Save > State… writes a new State file to make a record of changes to the dataset such as 
alignment or segmentations. The .idl file will be saved. 

Save > Binary and State writes new State and Binary files. This is necessary after one first 
generates a volume or after making changes to an existing volume. The .idl and .data files will 
be saved. To preserve the previous files, choose a new name for the .idl file different than the 
previous name. The .data file automatically gets the same filename as the .idl file. (It’s not 
necessary to add .idl after the new file name.) 

NOTE: When saving files, on Unix platforms (including Macintosh), the directory to which 
they are to be saved must already exist. 

  

Figure 31: File save dialog boxes for Windows(left)  and Unix platforms (including 
Macintosh) 

In the Save in / Directory field, enter the pathway to the directory 
where the files will be saved and select <Enter> (on the keyboard) 
or Filter to set it. In the File name / Selection field, enter the name 
of the new file(s) and select Save / OK. (One can also navigate 
these dialogs by left-clicking and double-clicking with mouse in 
accordance with the standard practices of that particular platform.) 

Write… opens a window that permits creation of a set of files, 
each containing an individual projection or volume image in either 
PICT or TIFF format. Use this tool to save sequences of 
projections or slices for illustration or animation purposes.  

We recommend writing 16 bit TIFF images unless 
you want to print the TIFF files. 
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Adjust the Start and Stop sliders for the range of projections or slices, and select the Write 
button. A file dialog will be displayed; the output sequence of files will have names that start 
with the filename, each with an appended sequence number corresponding to the projection or 
slice number of the image it contains. 

Delete Proj/Slice removes an undesirable projection or volume slice from the series, which 
can be necessary because of bad focus, noise, or other image problems. 

Quit, exits EM3D. A warning dialog may ask if you want to save EM3D file(s). 

3.2.3. The image menu 
Scaling is used to set which part of a linear contrast range visually best suits the data, e.g., for 
better fiducial acquisition with noisy data or to better view images during segmentation. It 
changes the image scaling range for either projections or volume slices (depending upon 
which mode is selected) based on the cumulative distribution function, which is shown as a 
plot versus gray value. The Min Clip and Max Clip fields set the percentage of pixel values 
that will be clipped; the corresponding gray values are displayed as the vertical red lines on 
the graph. For example, if both fields are set at 1%, then the darkest 1% and the brightest 1% 
of the pixels in the image will be clipped at, respectively, black and white, while the 
remaining 98% of the pixels will be linearly scaled between black and white. Increasing both 
clip values together increases the image contrast.  

On the lower left corner are two radio buttons, Absolute and Relative. Absolute scales each 
image based on the range of data values in the entire tilt series or volume, while Relative 
scales each image based only on that projection or slice. Relative is the default mode for 
projections, while absolute is the default mode for volume slices. The Invert button reverse 
the grayscale, generating a negative image that is often useful for segmentation. 

 

Figure 33: Image Scaling 

Review x,y/x,z/z,y create animation sequences of the projection or volume-slice data. In 
projection mode, only the x,y review is available; in volume mode one can review any of the 
three orthogonal slice orientations. When selected, the appropriate image window will be 
sequentially updated with the entire set of projection or slice images. This first review 
sequence serves to create an animation that is then displayed in a new window (see Figure 
34).  
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Figure 34: Review animation window 

 

This window provides extensive control over the animated review.  On platforms that have 
fully licensed versions of IDL, MPEG movies may be written. 

Average x,y is a toggle that provides a 3D extension of the slice averaging controlled by the 
Averaging slider (see above); it only functions in Volume mode. When selected, the 
averaging slider now controls a volumetric boxcar smoothing of the data, with a setting of 1 
corresponding to a 3×3×3 smoothing kernel, 2 corresponding to a 5×5×5 kernel, and so forth. 

Invert provides the same function as Invert in the Scaling window. 

Show controls the display of various image properties in Volume mode: 

• Crosshairs: toggles on and off the blue crosshairs in the three volume 
windows.  

• Transverse: toggles off or on the (x, z) and (z, y) views. 

• Segmentation  > Objects / Regions:  toggles on or off color overlays that 
indicate segmentation boundaries or locations (see Segmentation). 

3.2.4. The process menu 

Decimate 

The Decimate slider controls the size of the reconstructed volume. Projection images are 
often quite large, e.g., each 2048 × 2048 pixel image requires 8 MB of memory. 
Consequently, the corresponding size of an undecimated reconstructed volume can be huge, 
e.g., 1 GB for a 128 slice reconstruction. Such huge reconstructions are time consuming, and 
can tax or overwhelm the memory (RAM) capabilities of many desktop computers. The table 
below illustrates the dramatic reduction in image volume (computation time) achieved 
through decimation. 
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Decimation 
Level 

In-plane 
dimension 
reduction 

Volume 
reduction 
(Projections) 

Volume 
reduction 
(Volume) 

0 0  0 0 

1 1/2 1/4 1/8 

2 1/4 1/16 1/64 

3 1/8 1/64 1/512 

 

The reconstructed volume size is indicated by the text field, Volume array size = ## MB, 
located near the middle of the Reconstruction window. Note that setting the reconstructed 
volume Data type to Real will double the size of the volume array.  

Use Decimate judiciously — it is an irreversible step. In order to preserve the original data, 
save the decimated file with a new name. If it is decided that a decimated file is not 
appropriate Cancel and do not save.  

 

Figure 35: Decimate data 

Core 

Use Core to permanently cut a subvolume from the existing volume. Select Process  > 
Core… to open the Core Volume window (Figure 36). 

Define the core area by holding down the right mouse in the (x, y) view of the EM3D 
Visualization window. Drag the mouse to create a square box that will define the boundaries 
of the “cored” subvolume.   

Next, define a start slice and stop slice to specify the depth limits of the new volume. This can 
be done by manually adjust the Start slice and Stop slice sliders in the Core Volume window. 
Alternatively, use the navigation controls in the Visualization window to display the slice 
where the new volume should start, press Set Start and then navigate to the last slice for the 
new volume and press Set Stop.  

Create the new volume by pressing the Core button. Press Cancel to abort the entire process. 
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Figure 36: Core Volume window 

Use Core judiciously — it is an irreversible step. In order to preserve the original data, save 
the “cored” subvolume using a file with a new name. 

Filter 

The Filter menu controls a simple boxcar filter to reduce noise 

• Smooth… opens a simple dialog containing two numbers. The first is the 
size of the boxcar filtering kernel ; the second is the number of smoothing 
iterations to apply. Smoothing can be applied to the projections (2D 
smoothing) or the volume (3D smoothing). By default these numbers are 3, 
1 – that is, in volume mode a 3×3×3 boxcar applied once. Like decimation, 
smoothing should be used judiciously. 

• Commit makes the filtering permanent, so that it cannot be Reset or 
Restored. 

• Reset removes the filtering by rereading the projections or volume from the 
Restore file. One can also remove smoothing by selecting File > Restore. 

The other Process menu selections, Align…, Reconstruct…, Segment…, and Render… are 
described in the next chapters. 

3.3. Alignment controls 

From the EM3D Visualization Window, select Process > Align to open the Projection 
Alignment window. 

The Projection Alignment window contains one drop-down menu, the File menu: 

• Revert allows convenient error handling during alignment-offset 
calculations. 

o Single-step “undoes” the previous alignment set of fiducials 
deletions and alignment-offset calculations.  

o Calculations removes all calculations and deletions, bringing the 
alignment procedure back to the results of the Index step. 

o Indexing brings the process back to the results of the Acquire step. 
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• Reset removes all alignment data. 

• Close hides the Alignment window. 

Acquisition controls 

Floating-point slider values can be adjusted directly, or by entering a specific number in the 
text field and hitting the <Enter> button on the keyboard.  

• Acquire button initiates acquisition. 

• Fiducial Diameter slider controls the smoothing. Larger numbers increase 
the marked areas and reduce noise, but excessive numbers will merge 
together closely spaced fiducials. Typical range: one-half to one-quarter of 
the actual diameter of the fiducials. 

• Contrast slider controls the fiducial marker contrast enhancement. Larger 
numbers increase fiducial visibility, but also increases noise. Typical range: 
0.5—0.9. 

• Threshold slider controls detection threshold. Larger numbers increase the 
number of detected fiducial positions. Typical range: 0.25—0.5. 

• Maximum # of fiducials slider will adjust automatically as changes are 
made to the three parameters above. It can also be manually adjusted to deal 
with unusual circumstances. 

Index controls 

• Index button initiates fiducial indexing, that is, correlating the identities of 
fiducials between projection images. 

• Twist angle slider controls the rotation angle of the tilt axis around the 
depth axis of the zero-tilt projection. As long as the twist angle is < 45º, it 
will normally be automatically calculated during subsequent alignment 
steps. 

• Reference projection button indicates which projection was the indexing 
reference. Pressing this button makes the Visualization window display that 
projection. 

Calculation Controls 

• Calculate button initiates the iterative calculation of alignment offsets, 3D 
fiducial positions, and the twist angle. 

• Delete button removes fiducials selected in the Fiducial list, removing 
previous alignment offset data. 

• Fiducial positions / errors radio button controls the information displayed 
by the fiducial list. 
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• Fiducial list displays detailed information about fiducial positions or errors, 
and can be used to select fiducials for deletion or adjustment.  

3.4. Reconstruction controls 

From the main Visualization window, open the Reconstruction window by selecting Process 
> Reconstruct; see Figure 37. Near the top of the window are five sliders that control the 
position of the reconstructed volume within the 3D coordinate system established by the 
Alignment process, while controls in the lower half of window adjust various numerical 
aspects of the reconstruction. The specific controls are: 

• Initial z index, z thickness (pixels) – Initial position and thickness of the 
reconstruction, in pixels, along the depth (z) axis. Default values 
approximately center a slab that is half as thick as it is wide and high. 

• Tilt offset – Features within the specimen volume may sometimes be tilted 
around the y-axis with respect to the zero-tilt slice. This control adds an 
offset to the specified tilt angles, and can be used to make a particularly 
specimen feature more closely normal to the depth axis.  

 

Figure 37: Reconstruction window 

• Interpolation mode – Controls the form of interpolation used for rotating 
the projections. Bilinear (default) is faster but less accurate than Cubic. 

• Projection Mode – Controls how the image data is interpreted before 
reconstructed. Linear (default) takes the EM data at “face value,” the 
optically thin approximation. Log mode treats the EM data as optically 
gray, taking the logarithm of the image data before forming the back-
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projections. Use linear mode for thin samples, log mode for thick samples. 
In Log mode, the Log minimum slider becomes active; adjust this value to 
control the contrast of the reconstruction. 

• Decimate – Combines pixels to reduce size of data by 2N, so that 
decimation of zero (default) is 1:1, decimation of 1 is 2:1, decimation of 2 is 
4:1, etc.. Use large decimation values to perform fast reconstructions that 
permit convenient assessment of parameter settings. 

• Scaling – Controls the treatment of artifacts created by the high-pass 
weighting process in Filtered Backprojection. The default value is 1%. 

• Masking – Controls the masking of linear artifacts produced near the edges 
of the projections associated with finite twist angle and alignment offsets. 
Default value is 5 pixels. 

3.5. EM3D visualization controls – volume mode 

This chapter was included to preserve the correspondence of sections numbers in the Tutorial 
and Reference Manual. The Volume mode of the EM3D Visualization window is covered in 
chapter EM3D Visualization Controls. 

3.6. Segmentation controls 

High-contrast structures with a simple topology, such as most trilaminar membranes, can be 
segmented automatically. Lightly stained structures, such as the rod-like filaments in the 
Synthetic dataset, will often require manual segmentation. All structures with complex 
topologies will require manual segmentation, although regional segmentation can be used to 
develop approximate models. 

Open the Segmentation window by selecting Process > Segment… from the EM3D 
Visualization window.  
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Figure 38: Segmentation window, automatic and manual modes 

File menu 

• Re-anchor removes automatic segmentation and reverts to the original user 
anchor points. 

• Clear Object removes all segmentation of the selected object. 

• Close hides the segmentation window. 

Regions menu 

• Map initiates the regional segmentation mapping process. 

• Reset removes any regional segmentation map. 

Drawing menu 

• Change Anchor Mark – The color, shape and size of the segmentation 
marks can be changed. 

Selecting and identifying objects 

All segmentation objects have a name, which is displayed and edited in the text field at the 
top of the window. Objects are specifically identified by a unique index number, which is 
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selected using the slider control that is below the left edge of the text field. The text label 
below this slider indicates the segmentation Status of each object. Immediately right of this 
slider is the Volume width slider, which controls the size of any volume-rendering VOI that is 
associated with an object.  

Visualization display 

A colored overlay in the Visualization window provides feedback about the segmentation 
process. Display controls are: 

• Enable / Disable radio buttons turn the display on or off for the selected 
object. 

• Enable / Disable all buttons turn the display on or off for all objects. 

Segmentation modes 

Objects can be defined using two modes, Manual and Automatic, accessed by clicking on the 
“tabs” below the Status field. 

Manual mode 

In this mode, a closed path is manually defined on every slice containing a structural 
component. Define a path by clicking on several anchor points using the middle mouse 
button. The point locations are indicated by ‘*’ symbols. After three points have been 
selected, a closed path is interpolated between them. Continue placing points so that the path 
encloses that portion of the structure visible on this slice. Use the right mouse button to delete 
points as needed. Use the control buttons described below to continue the segmentation onto 
other slices. 

• Spline/Piecewise radio buttons control how a path is interpolated between 
user-selected anchor points. Spline mode uses cubic-spline interpolation; 
piecewise uses linear interpolation. 

• Segment adds all the points interior to the path to the segmentation object VOI. 

• Up copies the current set of anchor points into the next higher slice after 
first segmenting the current slice.  

• Down copies the current set of anchor points into the next lower slice after 
first segmenting the current slice. 

• Clear removes the current anchor points and deletes any contents of this 
slice from the segmentation object VOI. 

Automatic mode 

In this mode, an initial anchor path must be defined on a single reference slice. Define the 
path with a sequence of middle-mouse button clicks to create anchor points. Automatic 
software will use this path and other parameters to segment the reference slice and propagate 
this segmentation throughout the volume. 

• Topology radio buttons 
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o Open objects extend out of the image field. 

o Closed objects close within the image field. 

o Isolated objects are segments or blobs within the image field. 

• Search controls 

o Search button initiates a pixel search around the path. The 
minimum and maximum gray values for the search will be set 
based on gray values along the anchor path. 

o Surface width slider sets the diameter of the search region around 
the anchor path (in a fashion similar to setting line-width in a 
drawing program). 

o Minimum / Maximum gray value sliders allow manual control of 
gray values selected by the pixel search. It is scaled from 0 to 1000 
in which 0 represents black and 1000 represents white. 

• Segmentation controls 

o Segment button finds the median axis of the pixels selected by the 
search around the anchor path. This axis is converted to a new 
segmentation path. 

o Smoothing / Iterations sliders set the parametric smoothing 
applied during the segmentation process. The smoothing value 
should be set so that the path generated by pressing the Segment 
buttons follows the center of the structural component. Default 
value for iterations is 4. 

o Reference slice button indicates which slice was used to define the 
initial anchor path. Pressing the button returns the Visualization 
display to that slice. 

• Propagation controls 

o Propagate button initiates automatic propagation of the 
segmentation through the volume. 

o Start / Stop slice sliders set the range for propagation. 

o Set Start / Stop buttons offer an alternative means to set the 
propagation range when used together with slice navigation 
controls in the Visualization window. 

3.7. Model generation and 3D visualization controls 

All features for model generation and visualization are accessed from the EM3D Rendering 
window, which is opened by selecting Process > Render in the EM3D Visualization 
window. In general, it is also necessary to open the Rendering Control window by selecting 
File > Control in the Rendering window.  
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3.7.1. EM3D rendering window 
The EM3D Rendering window is a visual interface to the rendered models, and contains 
controls to modify the isodensity level of individual surface models. It also provides 
geometric or analytic information about each model. 

Model control and information 

• Objects / Regions radio buttons determine which type of isodensity surface 
model to operate upon. 

• Model slider determines which object or region is currently selected. The 
label field over the slider gives its name. 

• Enable / Disable toggle button above the Model slider can be used to 
quickly create or remove surface models. 

• Isosurface level slider provides precise manual control over the gray value 
that defines each surface model. The slider can be adjusted directly for 
immediate control. Alternatively, a specific number can be typed into the 
text field above the slider; hit <Enter> to create the surface model at the 
new level. 

• The small isodensity plot window below the slider provides a graphical 
interface for isosurface gray level control. The plotted curve shows the 
cumulative distribution function for the entire reconstructed volume. 
Models will generally be constructed at some point along the slope of this 
curve, with smaller (darker) values producing sparser models, and larger 
(lighter) values producing more extensive models. The vertical blue line 
indicates the current isodensity level for the selected model. Isosurface gray 
level can be adjusted by clicking with the left mouse button within this plot 
window. 

• The information display fields, Pos (center position of the object), Volume, 
and Area, provide information about the currently selected model. 

• The Overlay fields indicate the name, color bar, and scaling of any 3D 
colormap overlay that is presently applied to the selected model. 
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Figure 39: EM3D rendering window 

3D Rendering Display 

The large 3D graphics window (see Figure 39) permits interactive visual display of the 
models. When the mouse is positioned over this window, the Cursor is Over: label field 
indicates the label of the model closest to the mouse cursor.  

• Mouse buttons access different visualization control features. Specifically, 
click and hold the mouse buttons to access the following features: 

o Left mouse button-down initiates a virtual 3D trackball. Moving 
the mouse in this mode will rotate all the models about the center 
of the current rendering volume. 

o Middle mouse button initiates scaling of the models. An outward 
movement makes the rendered models appear larger; inward 
movements make them smaller. 

o Right mouse button initiates translation of the models. 

o Double-click the left mouse button to select that object for control 
or information display. 

• Zoom slider provides more precise control over the scaling of the rendered 
models. The number shown represents the relative change from the last 
zoom. 

• Home button restores the rendering to a standard viewpoint and scale.  

• Volume Decimation slider controls the quality of renderings with respect 
to the reconstructed volume. Specifically, a setting of zero (0) corresponds 
to full resolution, a 1:1 mapping between the models and the volume. 
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Larger numbers correspond to log2 reductions, i.e., a setting of 1 
corresponds to a 2:1 reduction, a setting of 2 corresponds to a 4:1 reduction, 
and so forth. 

File menu 

• Control… opens the Rendering control window. 

• Save VRML brings up file dialog so that the current 3D rendering can be 
output in a file format readable by various VRML viewers, or imported into 
other 3D rendering applications such as AVS. 

• Close hides the EM3D Rendering window. 

Surface menu  

• Shading offers two options that have an effect in Solid rendering style.  

o Flat uniform color shade across each surface polygon. 

o Gouraud interpolated shading across each polygon (default). 

• Style 

o Points renders every vertex of the model as a colored point in 
space. 

o Wire renders the model as a set of colored lines connecting the 
vertices. 

o Solid renders each polygon as a colored, shaded surface (default). 

o Hidden points renders only those vertices that are visible from the 
current viewpoint. 

o Hidden wire renders only those lines that are visible from the 
current viewpoint. 

Volume menu 

• Show / Hide toggles the display of volume-rendering model. 

• Scaling… opens the Volume scaling window. 

• Interpolation toggles the interpolated display of the model. Interpolation 
improves the quality of the display, but takes longer to refresh. 

• Coarse / Fine toggles the spatial resolution of the volume rendering. 

• Z-buffering toggles use of the z-buffer. The use of the buffer controls the 
ordering of surface and volume rendering, allowing different visibility 
effects. 
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• Compositing controls how the volume render is created; the various modes 
create different appearances. Default mode, alpha, is the most useful and 
popular. MIP (maximum-intensity projection) can also be useful. The other 
two modes, alpha-sum and average, produce other appearance effects that 
can be useful under unusual circumstances. 

Effects menu 

• Drag quality controls the display detail while interacting with the 3D 
Rendering display. Lower quality settings, Medium and Low, offer less 
detail but a faster refresh. 

• Perspective toggles the rendering of perspective in the current view. 

• Spin controls animation of the 3D display. 

o x- / y- / z-axis initiates a rotational animation around the 
corresponding axis. 

o Axis… opens a dialog to allow specification of an arbitrary axis, 
and then initiates rotational animation around that axis. 

o Isodensity initiates an animation of isosurface level for the 
currently selected object or region. 

o Increment… allows specification of the rotation increment in 
degrees or the isosurface level increment (in grayscale units) used 
for the rotational/isosurface level animations. 

o Rock toggles the animation mode between looping (default: 1 → 
N, 1 → N, …) and rocking (1 → N → 1 …). 

o When an animation is terminated, a query window opens asking if 
the user wants to write the frames of the animation sequence. A 
‘yes’ response initiates the writing of the frames as a set of TIFF 
image files. 

• Lighting… opens the Lighting control window, which controls the color, 
illumination pattern, and placement of up to seven light sources for the 3D 
display. 

• Clip Planes… opens the Clipping planes control window, which controls 
the placement of clipping planes in the 3D display. 

• Stereo… opens the Stereo control window, which controls the display of 
stereo information using red-green anaglyphics. The user must wear stereo 
red-green glasses. 

• Cut… opens the Cut control window, which displays one or more 
principal-axis cut planes overlaid on the 3D-model rendering. 
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3.7.2. Rendering control window 

 

Figure 40: Rendering control window 

This window provides lists of segmented VOIs, both objects and regions.  Various functions 
can be applied to one, or more, of the VOIs selected in these lists.  Subsets of these features 
are as follows: 

Segmentation VOI lists 

• Objects / Regions lists show all available segmentation VOIs to create and 
be operated upon as models. Any combination can be selected using the 
mouse, to allow application of various visualization commands, model-
generation commands, and calculations. Double-clicking any list element 
opens a dialog window to name or rename it.   

• Groups list provides access to user-generated collections of objects or 
regions. Clicking on a group selects all its members in the Object / Regions 
lists. Double-clicking a group element opens a dialog window to name or 
rename that group. 

Tabbed control panels 

• Color controls the color and opacity of all selected surface models. The 
current RGB color and opacity values are displayed on the sliders and the 
Current color patch near the bottom of the panel shows the mean color for 
all objects selected. As the sliders are adjusted, the New color patch shows 
the changes. Use the Apply button to modify the color and opacity of the 
selected models. The Front button controls rendering order; when making 
surfaces transparent (opacity < 255), use the Front button so that the 
models behind them become visible. 
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• Uncertainty, Proximity, and Thickness panels control various 
calculations that can be applied to the selected surface models (see chapter 
3.8).  

• Overlay controls the display of calculated results as vertex colormap 
overlays (see chapter 3.8.5, below). 

File menu 

• Rename provides another way to change the name of segmentation VOIs. 

• Select all permits convenient selection of all objects or regions. 

• Group provides a mechanism to label and collect logically related models. 
New groups appear in the Groups list with a default name (e.g., Group 1), 
where they can be renamed by double-clicking. To delete a group, double-
click it and enter an empty name. 

• Combine creates a new segmentation VOI by performing logical operations 
upon the selected VOIs. Union corresponds to the logical OR of the VOIs 
by creating a new volume that contains all of the points in the selected 
VOIs.  Intersect corresponds to the logical AND creates a new volume that 
contains points where all of the selected VOIs coexist). The Volume width 
slider controls the dilation of these VOIs during these operations. 

• Delete removes the selected segmentation VOIs, clearing them from the 
Segmentation window. Any associated models are also deleted. 

• Close hides the window. 

Surface menu 

• Show / Hide controls the visibility of surface models in the Rendering 
Window. 

• Enable creates surface models by the default polygonal surface generation 
algorithm. 

• High quality creates surface models by true tessellation rather than with 
variable-sided polygons. Tessellated models are more accurate, but take 
much longer to generate. 

• Disable destroys surface models. 

• Optimize initiate an iterative search for the isosurface gray value that 
produces the most reliable surface model. Before optimization, it is 
generally best to manually adjust the isosurface value to a relatively small 
value so that the initial surface is relatively sparse. 

Volume menu 

• Enable creates a volume model containing the currently selected object and 
region VOIs. 
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• Disable destroys the volume model. 

3.7.3. Lighting control window 
From the EM3D Rendering window open the Lighting Control Window by selecting Effects 
> Lighting… 

 

Figure 41: Lighting control panel 

• Light # selects one of the seven light sources.  

• Use the On/Off radio buttons to switch the selected light source on/off. By 
default the first 3 light sources are on.  

• Four types of light sources are available. By default the first light source is 
ambient, the second and third are positional light sources. 

o Ambient: The light source emits its light everywhere and in all 
directions. 

o Positional: The light source is a point light source at a specific 
(x,y,z) location and emits light in all directions from that point. Use 
the x, y and z sliders under Position to specify the location of the 
light. 

o Directional: The light is located at infinity and shines in a 
particular direction with parallel rays like the sun, for example. 
Specify the direction with the corresponding x, y and z sliders. 
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corresponding sliders. Use the Cone angle slider to change the 
cone angle of the light source, same procedure with Focus. 

• The Red, Green and Blue sliders change the color of the light source.  

• Intensity controls the luminosity of the light.  

• The Clear Light Button resets the selected light source ambient with 30% 
intensity. 

• The Reset All Button resets all light sources to its default values. 

3.7.4. Clipping planes window 
The Clipping Planes window controls a maximum of 4 clipping planes. Clipping planes cut 
away the portion of the model on one side of the plane. 

From the EM3D Rendering Window open the Clipping Planes window by selecting Effects > 
Clip Planes… 

• Use the Plane drop down list to selects a plane. The Enable checkbox 
initiates clipping for the currently selected plane in the Rendering window.   

• X, Y, Z sliders define the position of the clipping plane in the volume. The 
Theta slider defines the rotation angle about the y axis, and the Phi slider 
defines the rotation angle about the z axis.  

  

Figure 42: Clipping planes window and clip through vesicle and presynaptic membrane 

3.7.5. Cut control window 
The Cut Control Window displays one or more principal-axis cut planes overlaid on the 3D-
model rendering (see Figure 43). 
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Figure 43: Cut control window and visualization in rendering window 

• Opacity controls the opacity of the objects within the 3D rendering. 

• The XY, XZ, and ZY Slice radio buttons turn on or off the corresponding 
principal-axis cut-plane display.  

• The XZ and ZY Slice sliders specify the volume index of the slice to be 
displayed. 

3.8. Calculations 

3.8.1. Calculation controls 
Controls are accessed from the tabbed controls panels located at the bottom of the Rendering 
Control window. Three of these tabs, Uncertainty, Thickness, and Proximity, control those 
three calculations. Surface models must be created before initiating any of these calculations. 
The Overlay tab controls the display of the various calculated results as a colormap overlay 
on the rendered surface models. 

It should be noted that although decimation dramatically increases the speed of 
calculations, it also reduces the reliability of the results. 

3.8.2. Uncertainty 
This tab controls the spatial uncertainty calculation, a measure of the reliability of an 
isosurface model. 

• Reference object field displays the current signal-to-noise ratio manual 
reference object, and the current SNR estimate. 
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• Reference signal +/– noise field reports the current maximum signal and 
noise values, in arbitrary grayscale units, based on the currently selected 
Reference object and current minimum clip values for the Visualization 
window. 

• SNR Reference button sets the currently selected manual object as the SNR 
reference. 

• Calculate button initiates the spatial uncertainty calculation. 

• The plot window below the buttons displays a histogram that combines all 
of the spatial uncertainty results from the currently selected models. 

• The Min, Max, Med, and Bad fields display, respectively, the minimum 
value, maximum value, median value, and percentage of bad values for the 
combined calculated data ensemble. 

3.8.3. Thickness 
This tab controls the membrane thickness calculation. 

• Minimum and Maximum thickness slider set the range of the thickness.  

• Calculate button initiates the thickness calculation. 

• The plot window below the buttons displays a histogram that combines all 
of the thickness results from the currently selected models. 

• The Min, Max, Med, and Bad fields display, respectively, the minimum 
value, maximum value, median value, and percentage of bad values for the 
combined calculated data ensemble. 

3.8.4. Proximity 
This tab controls proximity calculations among the currently enabled surface models. These 
calculations require that one surface be designated as a reference, while one, or more, models 
be designated as destinations. Proximity values are distances between each destination vertex 
and its nearest neighbor vertex on the reference surface.  

• Reference field displays the current reference surface model. Nearest-
neighbor distances are calculated with respect to the vertices of this surface. 

• Destination list displays all object or region models selected for the 
calculation. Distance values will be calculated for every vertex on these 
surfaces. 

• Reference button sets the reference surface model. Only a single object can 
be set as reference. 

• Destination button sets the currently selected object or region surface 
models as destinations. 

• Calculate button initiates the proximity calculation. 
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• The plot window below the buttons displays a histogram that combines all 
of the proximity results from the models currently selected in the 
Rendering Control window. 

• The Min, Max, Med, and Bad fields display, respectively, the minimum 
value, maximum value, median value, and percentage of bad values for the 
combined calculated data ensemble. 

3.8.5. Overlay 
This tab controls the display of calculated data as a colormap overlaid upon their associated 
surface models. 

• Overlay pull-down menu selects which calculated quantity, uncertainty, 
proximity, or thickness will be overlaid. 

• Selected objects/regions list indicates which of the currently selected 
models have the currently selected calculated quantity available for overlay. 

• Minimum / Maximum fields set the numerical range for the colormap. The 
actual minimum and maximum values for selected models are displayed to 
the right of the editable text fields. 

• Colormap radio buttons controls the mapping between the numerical 
values and vertex colors. Constant imparts a single, user-selectable color 
the specified minimum—maximum range. Table associates a colormap 
with the current minimum—maximum range. 

• The Colormap graphics patch displays the current map. Click on the map 
to change the color or colormap. 

• The Undefined value graphics patch displays the color used to mark 
vertices with “bad” values; such values are produced when the calculation 
fails to produce a meaningful result. Click on this patch to enter RGB color 
values. The default setting is black, RGB values all zero. With this setting, 
bad values are simply ignored and “bad-flagged” model vertices appear at 
the previously set model color. 

• Apply button adds the overlay to the selected models. 

• Remove button removes the overlay from the currently selected models. 
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4. Appendix  
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4.1. Glossary 

CCD: A device made up of semiconductors arranged in such a way that the electric charge 
output of one semiconductor charges an adjacent one.  Used to acquire images like a camera. 

Cumulative Distribution Function: The probability that an image value is less than or equal 
to the current value, given the sum (numerical integral) of the image histogram f(i): 

F(x) = f (i)
i= 0

x

∑  

Decimation: The image or volume size reduction expressed as a log2 exponent, so a 
decimation of 0 means no decimation, full resolution. A decimation of 1 is 1/2, decimation of 
2 is 1 / 22 or 1/4, decimation of 3 is 1 / 23 or 1/8, etc. 

Fiducial Markers: also referred to as fiducials, colloidal gold beads placed on the surface of 
the TEM sample or incorporated into the sample used to align the projections. 

Intersection: Equivalent to Logical AND, meaning that a point is not added to the new region 
unless all selected VOI’s exist at that point 

Invert: Invert the gray scale of an image to create a negative image. 

Isosurface/isodensity: A region or surface in which the image gray scale is the same, similar 
to topographic lines on a map. 

Projections: Electron micrographs of the individual tilts in the dataset used to reconstruct a 
3D volume. 

Radio Buttons:  A group of buttons in which exactly one button is selected at a time. 

Signal-to-Noise Ratio:  The ratio between ‘signal’, the desired quantity measured by an 
image, to the ‘noise,’ the random variations in that quantity. In EM tomography, the signal is 
usually the contrast between a structural component and its adjacent background, while the 
noise is a complex function of the EM projection image formation and subsequent 
tomographic processing steps, so SNR is usually estimated empirically from the standard 
deviation of a relatively uniform background portion of the reconstructed volume. 

Slices: These are the 2D images that are virtually sliced (interpolated) from the reconstructed 
volume. 

Tessellation: Creation of small triangles that represent a surface and can be used in surface 
rendering. 

Transverse: The 2 orthogonal views to the x,y plane – the (x,z) and (z, y) planes. 
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Topology: Properties of geometric figures or solids that are not changed by stretching or 
bending.  Donuts and picture frames have equivalent topologies. 

Twist Angle:  The rotation of the projection tilt axis about the depth axis 

Union:  The logical OR of two or more objects, i.e. considered true if any object lies in the 
space 

Vertex: A point in 3D space that defines a corner of one or more polygons. 

Volume of interest: A subset of the volume containing defined by the user or an object. 

Voxel: Short for volume element, the smallest distinguishable cube in a three-dimensional 
image. 

4.2. Acronyms 

• CCD: Charged-Coupled Device 
• EM: Electron Microscope 
• MIP: Maximum Intensity Projection 
• MPEG: Moving Pictures Experts Group, digital video format 
• MRC stack: output dataset from the microscope 
• nm: nanometer 1x10-9m 
• RMS: root mean square  
• SNR: signal to noise ratio 
• TEM: Transmission Electron Microscope 
• TIFF: Tagged Image File Format 
• VOI: Volume of Interest 
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